Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
69&78 coupe Deville, 91&94 Fleetwood brougham
Joined
·
2 Posts
Discussion Starter #1
I just purchased a 1969 coupe Deville, the dash isn't working, I don't have interior lights
And speedometer doesn't work. However headlights work as well as blinkers. What can it be? Thank you for your help in advance!
 

·
Registered
1970 Coupe De Ville//Cessna 172
Joined
·
551 Posts
Re: 1969 coupe Deville dash issues

What do you mean "dash isn't working?" When you say blinkers, do you also mean the blinkers on the dash? Do you have any idiot lights?
The instrument cluster could have a bad ground. I have a 70 and the dash lights are finicky. You have to turn the headlight knob back/forth to get the dashlights to come on.
Give us some more info, please.
Jeff
 

·
Registered
1970 Deville Convertible
Joined
·
309 Posts
Re: 1969 coupe Deville dash issues

Yeah, agree with Jeff, need a clearer description.

Speedo works off a cable going to the transmission, is completely independent of anything electrical. Do you have cruise control?

As far as the "dash not working", check the fuse box for burned out fuses. Check them with a continuity tester to make sure they are making a good connection in the fuse box.

Has the car been "monkeyed with"? meaning have prior owners done some "custom work", which could be the source of the "dash not working"? Sometimes its a challenge when others before you have mucked up the works. Hopefully it is a fuse.
 

·
Registered
69&78 coupe Deville, 91&94 Fleetwood brougham
Joined
·
2 Posts
Discussion Starter #4
Thank you for your responses!

The dash is out completely - dead. Idk why I thought that maybe the signals had something to do with the dash... Such a girl I know! Haha

I checked the fuses and they're good, and yes it had some custom work done prior to purchase. :confused: I will.try as Christian suggested. Thanks again.
 

·
Registered
2003 Deville base, 69 Eldorado, 68 Impala, If I tell you the rest......well....
Joined
·
492 Posts
Re: 1969 coupe Deville dash issues

Light bulbs, mechanical speedometer/works odometer also. Turn signal switch in column. Wires, fuses. Headlight/dash switch. Good ole troubleshooting.
 

·
Registered
77 CDV, 06 DTS III, 69 FWB
Joined
·
10,022 Posts
Re: 1969 coupe Deville dash issues

If all the fuses are good, it's possible you could have a bad headlight switch, or that the dimmer rheostat in the headlight switch is bad or needs cleaning. Check that the speedo cable is connected to the speedometer and the transmission. If it is, and the speedo still doesn't work, the cable may be broken or kinked. Does the odometer work? Also, check to make sure all the bulbs are present and good.
 

·
Registered
1969 DeVille convertible, 1967 Eldorado
Joined
·
4 Posts
Re: 1969 coupe Deville dash issues

I have a similar issue. The only light that works on my gauge cluster is the gen light. No other lights work. Not even the turn signal indicators. Fuses all look good. What else could it be?
 
1 - 7 of 7 Posts
Top