Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey all! look I'm having problems w/ my 1969 coupe deville. It's doing this thing where when I romp on it, it surges (fluxuates power) and bogs down really bad. It's at all times. not just takeoff. I think it's the fuel pump because it's tough to start in the morning too. now in first gear, halfway through the gear everytime, it always stumbles. Now I did put on a new carb but I adjusted the metering screws on the front and the idle screw properly. and hey I know it's not related but when it's too the floor in first, it won't shift into second until I let off the gas. is that a clogged tranny filter mabey?? I did a poor man's stall test ( one foot on brake, one on gas to see if it stalls or stumbles bad and it doesn't stumble w/ moderate acceleration. it spins tires. I havn't tried the poor mans stallwith the gas to the floor yet so I can't tell you what it would do. but it works fine on the road until you open up the fours (except for that predictable stumble in first (what is that?)).Please help!!! thanx alot guys!!!
 

·
Registered
Joined
·
193 Posts
I had a bogging problem when when I rebuilt a 350 Chevy and put a brand new Edelbrock carb on there. It turned out that the fuel filter got dirty almost immediatly, being it was a 1977, and I guess plenty of dirt in the tank. Changed the filter and the problem disappeared. And that was all with an in-line filter. Your probably running a Rochester carb with that little stone filter at the fuel inlet, right?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
ya but i'm not running a fuel filter in it right now. it was sitting for 10 years but i drove it home w/ no problem except the bogging down
 

·
Registered
Joined
·
193 Posts
If you really suspect the pump, disconnect the line at the carb and put a can or something under the line and crank the engine. Then you can see if your pumping a decent amount of fuel. The manual should tell you how much it should pump on what amount of time.The idle mixture screws only affect idle sothat wouldn't be your problem. Did you put the new carb on before you drove it home? And did you drive it like that without the filter in it? Alot of sediment can collect in a tank since 1969.The lines can even be corrodid and limiting fuel flow.Rochesters have small fuel bowls to begin with, so limiting flow would keep the bowl from having the full amount of fuel in there.When all is running correctly there shouldn't be any hesitation on launch, just a crisp take off...The secondaries can be adjusted when to open by a screw on the side.You'll see a rod coming from the front vacuum pull-off going over the coke thermostat. The rod goes into a slot on a piece of metal that controls the air valve.Move that piece of metal a bit and you'll see a screw. That's the adjustment screw. Holding that screw is a set screw with an Allen head underneath it. You loosen the Allen screw and adjust the other then re-tighten the Allen. Don't turn it much, a quarter turn or less and remember where you started from, in case you don't like your adjustment. The air valve( the plates above the secondary plates) are what control when the secondaries come in.It's an "on demand" set up.
 

·
Registered
Joined
·
6,471 Posts
I'd be very careful instructing someone unfamiliar with carbs on these types of adjustments.
The mere fact that he is operating the car without a filter and doesn't see how that could be causing a MAJOR problem, is enough to tell me this is NOT somebody that should be playing with a carb.
Rochesters, as well as other carbs TOTALLY depend on tiny parts and precise adjustments for proper operation. Without someone to give some "hands-on" guidance here, there's a VERY GOOD CHANCE that this guy's gonna be buying a carb soon.
Angela's right about the idle mixture screws, they only effect "idle" operation, hence the name. If there is no filter, chances are VERY good that you've sucked debris into the fuel inlet and it is now partially jambing the float, or some other passage. If the car's been sitting, the carbs accelerator pump is probably shot and that will give you a hell of a flat-spot off idle. As for the Bogging-down, if the secondaries aren't opening, then you won't be bogging down, it'll just seem down on power. It's when the secondaries open that you'll be putting the load on the whole system. They will allow much more air into the engine and it will need to be accompanied by large amounts of fuel. Usually, a bogging down like you mentioned will be caused by the secondaries opening and there NOT being sufficient fuel flow with them. THAT's why you need to have a good fuel pump, properly set float, and of course secondary rods and jets that are operating properly.
Carbs have a way of screwing up if they're left to sit for a long time, especially with fuel left in them. That's the first place I'd look for your solution.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
did anybody see that I put a new carb on? I put it on after the trip home. but your answers are still sketchy. is it the fuel pump, excess sediments in the tank, or misadjusted secondaries? I need help please.... :crying2:
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
oh yeah, when i have the hood open and I'm revving it up, opening the 4s, I see little.........i dunno............spits of gas or something popping up out of the secondaries................ :confused: :confused: :confused:
 
1 - 10 of 10 Posts
About this Discussion
9 Replies
3 Participants
Katshot
Top