Cadillac Owners Forum banner

1 - 2 of 2 Posts

·
Registered
1964 Sedan DeVille
Joined
·
13 Posts
Discussion Starter #1
Hi guys, so the temp is super hot here in summer... As such I replaced the majority of the cooling system. The water pump, hoses, clamps, etc... everything but the radiator.
Last weekend I had the car out for a Sunday drive. The temp was 40 (or 104 in Fahrenheit). I drove for about 45 mins and then stopped for a break. When I came back to the car I noticed a hissing noise from under the bonnet and a pool of lovely green coolant everywhere. I didn't have time to get under the car (as it is on Airride suspension and lowered when its in park). I did however notice the coolant coming from the bottom end of the radiator.
I waited around 30-45 mins then took the cap off the radiator, inspected under the car refilled the radiator. It took around 2 liters of water so I only lost half the coolant. I then started her up and drove her (cautiously) home keeping a keen eye on the temp gauge. The 45 min drive home, the temp gauge didn't move off 1/4 to 1/3 (which is normal operating temp for my car). I parked her in the garage then later had a good look under the car and inspected the radiator, hoses, etc. The only think I could find was the plug screw wasn't 100% tight. No cracks, all hoses/clamps where tight and it hasn't lost a drop since I drove her home. Is it possible that the heat and pressure caused the coolant to come out of the drain plug if it wasn't tight enough? Is there any other tests anyone can suggest to see if I do have a leak?
 

·
Registered
1964 Sedan DeVille
Joined
·
13 Posts
Discussion Starter #2
So I have decided to get a new Radiator. Being in Australia there are basically no options other than to import one. Can anyone recommend a good quality radiator? Or even ones to avoid? I am looking at a aluminium 2/3 row unit....
 
1 - 2 of 2 Posts
Top