Cadillac Owners Forum banner

1 - 11 of 11 Posts

·
Registered
2012 Escalade Premium
Joined
·
172 Posts
Discussion Starter #1
08 Escalade with 58k miles. When I press on the brake pedal it makes a groaning type sound. Anybody have this happen? Is there some kind of bushing that could have worn out?
 

·
Registered
2009 AWD Escalade Ultra Luxury Raven Black
Joined
·
1,800 Posts
Can you describe this groaning? Is there feedback in the pedal? Do you hear it coming from the engine compartment or outside next to the wheels or brakes?
 

·
Registered
2009 AWD Escalade Ultra Luxury Raven Black
Joined
·
1,800 Posts
Sounds like rotors to me. Needs a break job. Replaced mine at 30k. They were not wore out, I just had a bad rotor and replaced them all.
 

·
Registered
2012 Escalade Premium
Joined
·
172 Posts
Discussion Starter #5
It seems to be something in the pedal mechanism itself. I'll get a video as soon as I can, hopefully the sound will be able to be heard in the video.
 

·
Registered
'16 VSport (wife's), '10 Escalade, '97 & '02 SS Camaro's, '15 Silverado LTZ
Joined
·
1,131 Posts
Sounds like worn pads to me, might want to check them. Also, when I wash the Eldorado and put it in the garage with out driving it the brakes will grind somewhat until the rust wears down.
 

·
Registered
2008 EXT
Joined
·
31 Posts
I have the same problem with my 08. Its like a deeper squeak sound like the pedal hinge needs lubrication. It seems to happen worse when its warmer out. I have drenched it with wd40 and still cannot get it to go away. I know its internal to the cab and not brakes or rotors etc. It does go away sometimes.
 
Joined
·
12,778 Posts
Hi Maliburider,
I am sorry the WD40 didn’t remedy the squeaking sound in your Escalade, have you considered taking it into the dealership to get it looked at? If so, I’d be happy to assist you in finding the closest dealership if you send us a private message with your zip code.

Best,

Alex H.
Cadillac Customer Care
 

·
Registered
2012 Escalade Premium
Joined
·
172 Posts
Discussion Starter #10
Maliburider said:
I have the same problem with my 08. Its like a deeper squeak sound like the pedal hinge needs lubrication. It seems to happen worse when its warmer out. I have drenched it with wd40 and still cannot get it to go away. I know its internal to the cab and not brakes or rotors etc. It does go away sometimes.
Correct, mine is also internal to the cab.
 
1 - 11 of 11 Posts
Top