Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
My 07 STS-V occasionally at 50 mph, when you stomp on it, the car downshifts like its going to take off, but then no throttle and boost to 0. I have to let off the throttle and then all is OK. This has put me in some dangerous situations so now I don't trust it. No codes and my tuner can't find anything since it is sporadic. Anyone experience this? Thanks.
 

·
Registered
06 STS V
Joined
·
78 Posts
I have this occasionally also, mine (06) will also hesitate sometimes when I'm doing around 15 -20 turning onto a street or something and give it medium throttle. I'm thinking maybe dirty throttle body? but want to wait till I get a code or it gets frequent.
I picked up a supercharger/throttle body assembly on Ebay for cheap and just waiting for a good reason to swap out.
 

·
Registered
06 STS-V & 06 STS 4 (sold 2016)
Joined
·
2,723 Posts
My 07 STS-V occasionally at 50 mph, when you stomp on it, the car downshifts like its going to take off, but then no throttle and boost to 0. I have to let off the throttle and then all is OK. This has put me in some dangerous situations so now I don't trust it. No codes and my tuner can't find anything since it is sporadic. Anyone experience this? Thanks.
One possible suggestion; check those little plastic hoses that connected to/from the supercharger. They break easily. Had to replace one of mine once, but I knew I broke it, so I don't know what the driving result was (didn't drive it that way).
 
1 - 3 of 3 Posts
Top