Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
'07 Escalade ESV
Joined
·
3 Posts
Discussion Starter #1
Hey guys, first of all I want to say thank you everyone, this would be my first post with questions but after reading hours of information about how to fix various things that were wrong with my car (bought if off auction) I have narrowed the problems down to only a few. The major problem I'm having now is the radio/navigation. It had been stolen and the factory connectors were cut as well, but I had bought factory harnesses and re-wired them to what I double checked as the proper ones. Then I had purchased a radio with navigation(seeing that the back up camera was also stolen from it when I bought it I automatically assumed that it had navigation). I wired everything up and I'm getting no lights or display from the radio. When I press the power button I see the buttons light up for a splitsecond then turn off, I can move the screen and when I put a cd in it does take it and I can eject it. But there is no display and no audio whatsoever. I purchased the radio off eBay and the seller "says" it worked when they were selling it. I'm worried it's a bad one but I don't know if cadillac has a certain way of locking it. I know there are two options and I had called my local dealership to find out which it was but they informed me that without the factory one in there I can't know for sure. Any help would be greatly appreciated!!! I have a few more problems but I will keep reading to hopefully find the answers to them.
 

·
Registered
2015 Escalade and 2018 CTS-V
Joined
·
320 Posts
Sounds like a bad radio. I purchased a replacement radio from a reputable website that offered a warranty. It's more expensive but worth the peace of mind.

You can test this unit outside of your escalade. You can contact a car stereo shop and see if they have the reverse plug. Then just run 12 volts to it and see if it does the same thing. That will tell you if it's your wiring harness or the radio.

Good luck man, sorry you're having these issues. It's never fun.
 

·
Registered
'07 Escalade ESV
Joined
·
3 Posts
Discussion Starter #3
Thank you, I will definitely try that. If it turns out to be the radio I'm wondering if I can just install a non navigation system radio via plug and play. Hopefully it's my wiring but knowing my luck it's not
 
1 - 3 of 3 Posts
Top