Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Need help.... The heater on my esv don't want to get hot when sitting and running. If you push the gas a little and bring the rpm up it will start to feel hot. If driving it does fine but only does this when setting. This becomes a issue when you want to warn the vehicle before leaving on cold mornings. I had to water pump and belt replaced about 3 months ago and I have noticed that the temp Guage wants to jump from half position to the quarter position at any giving time. Could the cooling system need flushed???
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Just checked coolant level and it looks ok but the cap seems to have some sludge under it. Could the system have sludge build up in the heater core? I have not had this vehicle 6months so I'm trying to fix all issues.
 
Joined
·
12,778 Posts
007lexus, would you consider going to your Cadillac dealership for service? Their technicians can run the proper diagnostic tests for you, but I understand if you prefer the DIY approach. I'm available to contact your dealership on your behalf anytime to follow up on concerns for you, or schedule an appointment if you like, so email me at [email protected] for further assistance.

Best,

Katie
Cadillac Customer Service
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Update on the esv.... I checked the lines going to the heater core after driving and found one line hot and the other was cold. Proceeded to unplug the heater core quick disconnect lines at the fire wall. Then flushed the heater core out with a water hose and found alot of black trash coming out. Not sure if someone put some kind of stop leak in it or maybe old anti freeze but now it is fixed and blows hot again. Thanks for the support.
 
1 - 6 of 6 Posts
Top