Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
'10 CTS4 3.6L Wagon prem; '06 STS 3.6L base; '98 Seville STS
Joined
·
2,404 Posts
Discussion Starter #1
took it to autozone to get the codes read and its an EVAP leakage, the CEL is on but the message "check gas cap" only shows up once every 4-5 start up...but when ever i shift the car to 4, the message comes up. already changed the gas cap but that's not it.

here is the puffing sound i hear while driving, i have to turn up the volume to mute out the sound



December has not been good to me, from earlier on in the month, i got side swapped (not my fault).





and then last night, it was wet and my car spun out and hit a 2011 Odyssey smh. my front license plate mount absorbed the impact on my car lol but i messed up the ladies door









for the honda







she opened the back sliding door and the damn thing didnt want to close back..thats when the cops came. it had to be manually closed.
 

·
Registered
2006 STS 1SG & 2007 STS 1SE
Joined
·
13 Posts
If you can reproduce the noise when standing still, try the old hose trick to find the leak. Remove all the engine covers & and find a few feet of old garden hose (or eq.) and put one end to your ear. Use the other end as a probe.

Just be careful of the fan(s).
 
Joined
·
12,821 Posts
Mullah88, I'm so sorry you've been so frustrated this month. While I realize you're seeking DIY advice from other owners (and I'm glad to see them responding so quickly), I wanted to let you know I'm happy to help if you decide to involve a dealer at any point. For further assistance, email me at [email protected], and I can schedule you a dealer appointment so their specialized technicians can run the proper diagnostic tests on your vehicle.

Best,

Katie
Cadillac Customer Service
 

·
Registered
'10 CTS4 3.6L Wagon prem; '06 STS 3.6L base; '98 Seville STS
Joined
·
2,404 Posts
Discussion Starter #6
ill be taking it in to the cadillac dealership on south blvd charlotte on the 2nd of January (hope i get an ATS as a rental :cool:...covered), they're the ones that'll do the repair work (for some reason geico tried to send my car to city of chevrolet??). after that ill let them run a diagnostic
 

·
Registered
89 Deville, 94 Fleetwood,2000 DTS,2005 STS V8 1SE,20081SG
Joined
·
44 Posts
Damn Mullah, I feel your pain. Now its time to come back harder. One door closes another one opens. I had a simliar issue with my 05 N*. Try changing the purge valve. Look it up if your not sure what it is.
 

·
Registered
'10 CTS4 3.6L Wagon prem; '06 STS 3.6L base; '98 Seville STS
Joined
·
2,404 Posts
Discussion Starter #8
Lol updated, the purge valve was not hooked up smh.... Once it was plugged back up, the CEL went off and the puffing stopped
 
1 - 8 of 8 Posts
Top