Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
2006 STS4
Joined
·
3 Posts
Discussion Starter #1
Hello, I just picked up a clean 2006 STS4 a few days ago for a good price. I'm in love with it. It has 150k mi on it and needs a few things. Most prominently is the display is blank at all times after start up, however the audio can be heard. I have not spent much time diagnosing it. I have noticed if I pull the fuse for the circuit or unplug the unit and reconnect the circuit the unit will boot up and work fine until the ignition is cycled off and back on. I've searched for similar symptoms but none of the threads I have come across never came across a solution. I did basic checks. I'm currently leaning towards poor battery. I keep forgetting to bring my multi-meter home from work. Any help is appreciated. Unit works flawlessly and adjustment to settings can be made and even my iphone can be linked through blue tooth.
 

·
Registered
08 STS4 V8 1SG & 04 SRX4 V8 & 01 Monte SS
Joined
·
4,988 Posts
I'd start with replacing the battery, it was what I was thinking as I read your post before you even got to the point where you suggested it on your own.
These cars are HARD on batteries and typically last 3-5 years tops.
Get the battery for the 08+ STS and trim or remove the battery cover your car has, its a much stronger battery than what the 05-07 had.
The 08+ could be Top Post or Side Post IIRC (my 08 is top post) so make sure you get the correct post style.
 

·
Registered
2006 STS4
Joined
·
3 Posts
Discussion Starter #3
OK. Just picked up a battery. That's the correct size. Still same problem. Been looking at wiring diagrams. Unsure of why unit wont power up on its own when the vehicle is started. Like I said information screen works fine after system is reset with the key on. Or unit is plugged in while car is on. Any help would help. Not sure if anyone has come across a similar issue.
 

·
Registered
2006 STS4 V8 1SG & 2007 STS V8 1SE
Joined
·
8,178 Posts
It may only look like the right radio for your car. Check the part number. In these cars, the accessories are always receiving power and may just be in stand-by awaiting the network signal to begin the start-up sequence. The Nav/Stereo head-end should begin start-up as the driver approaches the car, even before opening the door.
 
1 - 4 of 4 Posts
Top