Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
So i have an 05 SRX that has an issue starting at the moment. Basically I know when it will act up before I even go to crank it becuz i notice the check engine light does not even illuminate to let u know the ecm is powered up. Sumtimes im able to just disconnect the battery and reconnect and everything goes back to normal. Light will come on and car will start.

Im looking for a "diagnostic tree" on how to check if my ECM is fried? Its super easy to access so If I could just probe certain prongs within the harness to determine whether it is bad this would be helpful before I go buy a $400 computer that id have to take to a dealer to have programmed for another $100 just to fix this truck.

Ive got 12.6V at battery as well as Ive checked the obvious grounds for the computer which check out at 12.6 as well...

ive had a ton of problems thus far with this truck. I made a poat last year regarding a P0301 code I was getting and this new problem has stemmed from that I believe. Basically because I 2nd guess myself. To diagnose the 301 code I checked for spark and fuel which I had both. Then did compression check and got 20psi on #1 and near 120psi for cylinders 3 and 5. So then i did a leak down test which pointed to the air coming out of the spark plug region. So i tried a helicoil which was my first one ever and it didnt work. Long atory short truck sat all winter after that and i just recently took to dealer to have them re diagnose. They basically told me they think the threads are bad too bit when they returned the vehicle it wouldnt even start at the dealer, which ive never had a problem before. So i held the hood open while a tech monkeyed with the ecm while the damn battery was connected. I never touch ecm plugs without disconnectin battery and I think this is why my ecm is fried now. Also my driver door buttons stopped workin when this happened too.

Its all intermittent tho cuz I got home jiggled the ecm wires a bit myself with battery disconnexted and all of a sudden drivers door buttons work and car starts. I went drove it, left it for 30min come back out no check engine lite no start and drovers door buttons dont work again!!! LOL Wtf??? Any suggestions b4 I go spend on new ecm. Sorry 4 such a long description.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #2
http://m.youtube.com/watch?v=0Y2CtfZJtOM

This youtube video is a duplicate of my problem with the SRX 3.6L.

unfortunately I do npt have a nice scan tool like his. But I tried jumping the starter relay when problem is present and engine starts. I just want to know how to make sure my ecm is bad b4 I just spend the money on a new one.
 

·
Registered
05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
Joined
·
3,177 Posts
First you need your codes read with a scanner that will read ABS codes. Otherwise you're wasting money and time chasing ghosts.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
What do you mean? This has nothing to do with abs....i do have access to a snap on code reader thru a friend, but what is the purpose?
 

·
Registered
05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
Joined
·
3,177 Posts
Some code readers only read powertrain codes (P). There are also B,C and U codes. A reader that gets ABS codes will read all 4. There are well over a thousand codes so why not take advantage of the wealth of information they contain. Your symptoms tell me you have 'U' code(s).
 
1 - 5 of 5 Posts
Top