Cadillac Owners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
So a quick run down on my dilemma. As of most issues I read on the forums after my LS7 clutch swap my car ran great and on the third time I went to start it the lights on dash went out besides check engine light. This lead me to believe it was the clutch position sensor so I put a new AC Delco one on and same issue. Pulled the starter relay and swapped it with another and same issue so I jumped the terminals and it fired right up. So I bit the bullet and took it to a local dealer. They couldn't figure it out then after 2 days they stated that they found the issue and it was a bad ignition theft module. Replaced and low and behold it wasn't the issue. So a few days later they called and stated that it was a bad wire between the firewall and driver front fender and that the clutch switch wasn't getting 12V with pedal depressed. So I pick up car when they said it was fixed and noticed they used a splice connector above the clutch position switch, after they cut the purple and white wire only to crimp in a new piece of wire which made no sense. I was not the least bit happy that they ran a new wire all the way to the pcm with another splice connector. Should I take it to another reputable dealer or just run it like it is since it starts now? I'm more mad about all the hacks to my harness with all the crappy connectors.
 

·
Super Moderator
'05 CTS-V
Joined
·
8,024 Posts
If they used good splice connectors and a proper crimp tool, then they're arguably better than a soldered connection. If they used cheap splice connectors and crimped it with pliers, then I'd probably cut them out and re-do them with my own high quality splice connectors and ratcheting crimper.

I'd be inclined to not worry about it if it's working fine.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
They spliced in a 6 inch wire where they cut the purple wire on the oem clutch position sensor connector then used a snap lock connector and ran a wire from that new spliced piece to the pcm where they used another snap lock connector. So when they cut the purple wire on the oem plug connector, if you were to remove what connector they crimped on there is not enough wire to attach back to the oem connector since they cut it so short to that connector. I'll try to post some pics.
 

·
Super Moderator
'05 CTS-V
Joined
·
8,024 Posts
By snap lock connector do you mean a "vampire tap", like one of these - https://www.diyelectronics.co.za/store/8841-thickbox_default/tap-wire-splice-connector-18-to-14-awg-vampire-tap.jpg? If so, that's pretty bush league, and I wouldn't want that long term. But it sounds like they hosed you and cut the wire off very close to the connector, so fixing it more cleanly might be an issue.

If you're really concerned about it, GM does sell most connectors as pigtails, so you could buy a new connector (which would come with 6" or so of wire) and splice that in.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Yes that's the part that ticks me off the most. I expected more quality from a Chevy dealership. I've been looking for the part number for that connector. I don't plan on selling it so I want it to last and with that snap lock on the pcm I doubt it will. I've contacted a Cadillac service tech and they laughed on the wiring and told me to bring it in and they would look at it.
579445
579446
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Forgot to mention that once I picked up the car. Drove it to the gas station then shut it off it wouldn't start again. Couldn't even jump the relay. Called the dealer and they came down lifted the car with the tow truck then told me my connector for solenoid was bad on my starter. Now I told them to check that terminal when they were checking the wiring and they said it was fine. That was the final blow where I was really pissed. Got the car started told them to lower the boom on tow truck and took it home.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Replaced the starter yesterday and this is what they did. I've never seen a shop with such negligence.
579494
579495
 
1 - 9 of 9 Posts
Top