Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
2004 cts
Joined
·
11 Posts
Discussion Starter #1
The service airbag light on my car flicked on then off quickly a couple of days ago (it also did it about a month ago), so I thought nothing of it. It did it again today, but it did not turn off. Has anybody else had this problem before? Also, what can I do to fix this myself? Any help would be greatly appreciated. Thanks.
 

·
Registered
Cadillac
Joined
·
137 Posts
mine's an 04 too. same problem. it came on and off for a whole day a few months ago and then never happened again till just yesterday. as i pulled into work to park it came on. when i got back in the car after work to go home it never came on and hasnt come on yet today. im guessing that it wont for a while if it was anything like the first time. i dunno ???
 

·
Registered
Cadillac CTS
Joined
·
86 Posts
Check under the passenger seat. If you have anything under there it could be pushing on the airbag sensor cable connector. Check the plug and then make sure that nothing rolles under there. I have it come on and off periodically in my car as well.

There are also many other posts about this problem. Just give it a search and you will find a lot of good information.
 

·
Registered
2004 cts
Joined
·
11 Posts
Discussion Starter #6
I did what you said and there isnt a problem now. Thanks. Also, do you know where the fuse for the airbag is? I looked in the manual and i couldnt figure out if it was in the box under the hood or the back seat. Thanks for your help.
 
1 - 6 of 6 Posts
Top