Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
02 sls 03 sls 07 cts
Joined
·
11 Posts
Discussion Starter #1
03 sls - 84k - creampuff. wife came home saturday and said temp guage was way up when speed was reduced after driving a while on highway. up to the one or two oclock position , or 3/4 mark if straight up is 1/2. said temp would drop down quickly if a/c was shut off. air temp about 85 degrees out.
i took it out for a spin and seemed alright even with varying speeds, and a/c on. left car running for a while once i got home, and slowly temp did rise. tried to slowly remove radiator reservoir cap, but to warm to remove.
let car cool overnight, started it with cap removed, a/c on. no steam or smoke from exhaust, let it run until temp was straight up on guage - with no bubbles appearing in tank at any time. a/c did not cool, even though a/c pump cycled on and off throughout. radiator cooling fans did not ever kick on, but not sure if there were on or not saturday. thinking it is low on freon, causing no cool condition, and possibly something wrong that cooling fans didn't start.
feeling alot better not having steam from exhaust, or bubbles in tank, but looking for advise before taking it to dealer.
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,441 Posts
The cooling fans should run in SLOW any time some A/C compressor function is set - and the coolant temp should stay at about 190 - 205 degrees at all times - at all times.

Hers's your temp gauge with notations on when things should happen................ (Cadillac Tech Tips and the sticky posts in Engines, Northstar) ...............

ALL of the diagnostics are in these forums - no need to take it to a dealership.
 

Attachments

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,781 Posts
You might start by pulling the DTC's.
Cooling fans should come on at about 224 degrees.
3/4 is about 245.
Also check for coolant flow from the purge line. Check it cold so as not to burn yourself.
 

Attachments

·
Registered
02 sls 03 sls 07 cts
Joined
·
11 Posts
Discussion Starter #4
seeing your temp notations, i say it never got to 2 oclock, but rather to 245 max. it never got so you could see the hash mark at twelve oclock before, except maybe restarting after being driven, and then, probably only up to 220, for a brief time. i figured the cooling fan should be running with the a/c on, and i definitely am certain, that it is not. so, i guess i have two problems to contend with, the non start of the cooling fan, and the lack of a/c cooling. figured i had a head gasket problem when i first heard of high temp reading, so feeling better over that. i truly love these old cars.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,781 Posts
Oops. Just realized Sub posted the same response while I was typing.


Yes, you have two separate problems. Engine temp and A/C.
Concentrate on the engine temp first.
 
1 - 5 of 5 Posts
Top