Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Water was thrown in the opened front pass window by another vehicle. Splashed the dashboard and puddled on the front pass floor. Not operating now, climate control, radio, back up/key left in annunciator (beeping). Staying On, ac comp engaged, blower motor at the slowest speed, wipers at the lowest delay. All the fuses in all locations are good. Pulled the ac comp/wiper/HVAC, fuses/relays as a temp fix. Could this be a BCM issue? if so, location, please! Or something else? Need Help. ty
 

·
-Administrator- 2002.5 F55 STS 2014 FWD Explorer
Joined
·
66,595 Posts
Welcome Aboard !!!! This thread has been moved to Seville from the VERY quiet Electrical forums.

Use this link from the stickies in the top section of this Seville forum to pull any stored trouble codes from the car's built-in scanner/memory system. Use the correct set of instructions by JimD. Use the embedded link to all code definitions to decipher and post your found codes. At least it's a diagnostic start.


Here are the 3 switches used to enter and use the system.

DIC controls.jpg
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Water was thrown in the opened front pass window by another vehicle. Splashed the dashboard and puddled on the front pass floor. Not operating now, climate control, radio, back up/key left in annunciator (beeping). Staying On, ac comp engaged, blower motor at the slowest speed, wipers at the lowest delay. All the fuses in all locations are good. Pulled the ac comp/wiper/HVAC, fuses/relays as a temp fix. Could this be a BCM issue? if so, location, please! Or something else? Need Help. ty
Welcome Aboard !!!! This thread has been moved to Seville from the VERY quiet Electrical forums.

Use this link from the stickies in the top section of this Seville forum to pull any stored trouble codes from the car's built-in scanner/memory system. Use the correct set of instructions by JimD. Use the embedded link to all code definitions to decipher and post your found codes. At least it's a diagnostic start.


Here are the 3 switches used to enter and use the system.

View attachment 572705
Thanks for the welcome, have a code reader. none stored, was 2nd place I had looked, did the batt disconnect, any idea what to do next?
 

·
Super Moderator
Joined
·
86,145 Posts
Don't rely on an aftermarket code reader. Use the onboard diagnostic (if they work).

Hard to imaging the BCM getting wet from what you described.

Leave it parked in the sun for a few days with the windows closed to cook it and maybe you'll get lucky and it will dry out.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Don't rely on an aftermarket code reader. Use the onboard diagnostic (if they work).

Hard to imaging the BCM getting wet from what you described.

Leave it parked in the sun for a few days with the windows closed to cook it and maybe you'll get lucky and it will dry out.
Thanks, but my code scanner is Pro/Plus Actron, with no codes on both ways. It was saltwater. Will be replacing the Climate Control and Radio, vehicle was dried with high-velocity airflow aimed at and under dash +36hrs. I just want to rule out any BCM issues if that's possible. Is there a test and where is it located?
 

·
Super Moderator
Joined
·
86,145 Posts
Salt water.........OUCH!

I think the BCM is under the dash, or at least it used to be. Might be in the electronics bay behind the rear seat now.
As for testing it, I'm sure there is a procedure, but you're gonna need a FSM or a subscription to www.alldatadiy.com
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Thanks, just got the fleeing driver's ins company info, either let me repair or sign that fat check. or both!
 

·
Registered
Joined
·
1,329 Posts
There are a whole bunch of grounds on the passenger side below the glove box, tucked inside the floor trim. I remember a grounding problem the affected the blower and something else. If water came in there, it may be worth checking those grounds. Getting those wet shouldn't be a problem, but crazier things have happened.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
Thanks, I got the radio to come to life, but no LCD screen. So no display of stations. time etc. The climate comfort control sys only sends outside temp to the DIC, nothing else operates. The 2 units illuminate with the interior lighting, A/c compressor engaged and blower running constantly the with comfort control harness plugged in, car ign on. I pulled the havc/ac comp fuses as a temporary fix. Both the units are stock, 20190913_152212.jpg 20190913_151608.jpg besides checking those grounds, any mods or control units in that area? No local junkyard has the used parts to test the harness.
 
1 - 10 of 10 Posts
Top