Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
03 cadilac deville
Joined
·
4 Posts
Discussion Starter #1
Hey everybody, I am new to this forum!

Heres a little info about me:

I'm new to Cadillac's, I am working on this car for a friend who has an 03 deville FWD engine code Y.i think it has about 102k on it.

A little history about me and this car so far:

About a month ago my buddy called me up to take a look at this shutoff issue it was having, you guessed it, CPS sensors were bad, replaced and good now.
Now there was a check engine light on for the TCC solenoid, replaced that using YouTube videos (1.5" workroom YIPPEE!)

I topped the trans level off to the correct level (with Dextron fluid), let it warm up and took it on a test drive.No codes yet but after having the car in "D" and shifts into 4TH, the car just revs at 50MPH!

Im kinda at a lost with out codes to go off of, the fluid is at the correct level with the right fluid, and I ran the transmission through all the gears at idle to "purge" any air.

My next guess at this would be doing a pan filter replacement, but i dont really think it will help.We do not know when it was replaced last though.

Is there a different purge procedure i do not know of? what am i missing? the car drives like a dream except at 50MPH!


I have used the search function with no hope, and i am mechanically inclined. I do not have access to a lift though.:crybaby:

Thanks for all your input!
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,783 Posts
Re: 03 cadilliac deville slips @50MPH after TCC replacement?!!!!

There is no pan filter on the 4T80E. Only a reusable screen.

Did you check the fluid idling at operating temperature? If you filled it with the engine off, it is way overfilled as the side cover will drain back into the pan and show empty.
 

·
Registered
03 cadilac deville
Joined
·
4 Posts
Discussion Starter #3
ok.i filled it while it was running on a level surface, small pours at a time and checking the dipstick.engine to full temps = trans fluid level @ Hot mark on dipstick.

----------

regarding the reusable screen, is it on the bottom like most cars? whats the orifice on the screen? small? any chance you have a pic handy? thanks!
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,458 Posts
Here's the speed/rpm tables for the VIN 9 and VIN Y powertrains, over 43 mph, TCC engaged, road cruise loads.

VIN Y is speed limited to 112, so that's why the numbers stop there.
 

Attachments

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,783 Posts
Here is a picture of the Scavenge screen. Couldn't find one in the trans, but you can't miss it when you drop the pan.

 

·
Registered
03 cadilac deville
Joined
·
4 Posts
Discussion Starter #6
ok, so do you think the new tcc solenoid is not engaging at 50mph? is that the only time it engages is at 45mph and up?

thanks for the pics!
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,783 Posts
No codes yet but after having the car in "D" and shifts into 4TH, the car just revs at 50MPH!
That is NOT indicative of a bad TCC solenoid at all. The solenoid simply locks the trans to the engine, taking the last 300 RPM slippage out of the torque converter. Revving at 50 MPH is something much more serious.
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,458 Posts
The TCC solenoid operates to port oil to the Converter Clutch at road load speeds over 43 mph in order to remove the last 300 or so rpm of slip in the converter. TCC drops out on moderate upgrades, acceleration as if to pass, power acceleration. As soon as engine/transmission loads reduce to a cruise status, TCC again engages. It's a viscous, as opposed to hard friction, clutch.

If you can accelerate moderately from stop and distinctly feel 3 gear shifts - 1>2, 2>3 and 3>4 - then as you ease off the gas at 45 see the rpm drop another 300 rpm or so, the TCC is functioning. If you get to 50-ish and the engine loses drive power - the car just sits at 50 - then something is wrong with 4th gear (overdrive) line pressures.......... and that's not a solenoid - it's internal pump problems.
 

·
Registered
03 cadilac deville
Joined
·
4 Posts
Discussion Starter #10
sounds like its not the tcc then.the car just revs up as i try to accelerate more to go faster and speed does not increase, like the clutch (if it was a five speed) is disengaged.I eased off the accelerator, put on my hazards and cruised to 35 to prevent worse possible damage.
 
1 - 10 of 10 Posts
Top