Cadillac Owners Forum banner

1 - 9 of 9 Posts

·
Registered
2003 Cadillac CTS (V6)
Joined
·
4 Posts
Discussion Starter #1
Good morning folks...

I've checked and haven't immediately found anything matching my issue yet. I have a 2003 CTS V6 with a 5 speed automatic transmission, and 175k+ miles. I began noticing that the transmission would get stuck in 4th gear, almost at random. I could shift down to 3rd, then back up to 4th, and then back into 5th (D) and more often then not, it would work ok. In a couple of cases, it would actually shift down to 4th, whilst going 65-70 on the highway, and not shift back up into 5th. Sometimes I could use the downshifting method to get it back in place, but sometimes I would have to park the car, and shut down/restart it to get it working again.

After checking the codes (which I don't have off the top of my head) at my local transmission shop, they found a Solenoid Misfire code. So, $350 and a week later, they replaced all 3 solenoids (despite the 4-5 one being the problem... Yeah, I've got a beef about that). This morning, on my way to work, excited that the issue should be resolved, I actually experienced both issues, getting stuck in 4th, and later shifting down and getting stuck in 4th.

I've done some research, and found that it could potentially be the ECM throwing bad codes, that end up getting interpreted by the TCM as a need to stay in 4th and not shift up into 5th, despite sitting at 3000rpm (I'm normally around 2300-2500rpm at 65-70 mph) and NEEDING to shift up.

Any ideas?
 

·
Registered
2005 CTS 3.6, 2016 Malibu 1.5T
Joined
·
359 Posts
Im not sure, but it sounds like this is normal? My car usually stays on 2700-3000 rpms when going at 80-90 on the expressway. 2200-2500 at 60-75
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,789 Posts
All depends on what set up is installed in the CTS. Some have X ratio while others have Y ratio for the differential.

So in order to compare, both CTS' need to have the same set up.

KOT
 

·
Registered
2003 Cadillac CTS (V6)
Joined
·
4 Posts
Discussion Starter #4
Well, the reason I don't believe it is normal, is because when it gets stuck, I'll be running at 3000rpm at 65mph, and 3000 - 3500+ at 70 and up. I also feel it shift down, and never shift back up until I either pull over and restart, or force it back to 3rd -> 4th -> 5th (which doesn't always work).
 

·
Registered
2003 Cadillac CTS (V6)
Joined
·
4 Posts
Discussion Starter #5
Update on this issue. Brought the car back to the transmission shop, and they reran the codes, so far the solenoid codes are not coming up (despite me having had them get stuck in 4th just prior to bringing it in). Instead, I'm getting an O2 sensor code, and one other code (I'll have to write it down and post again). This leads me to believe, that the solenoids are fine, but are getting a bad signal from somewhere else. Could it be the TCM or ECM?
 

·
Registered
2003 Cadillac CTS (V6)
Joined
·
4 Posts
Discussion Starter #6
Yet another update. The transmission guy says it's "in the transmission" and talked about the possibility of the clearance in the clutch shaft being too much, it won't shift back down. He said that there was no metal in the pan when he took it off, but said that the clutch doesn't create shavings when it wears down.

I have a feeling like I'm getting the run around, especially after this has been going on for nearly 2 weeks now. (I understand that his shop is busy, he says they have 60 cars there, but 2 weeks with almost no update unless we initiate it is getting a bit ridiculous.)
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,074 Posts
GigaWatts has not logged in for almost 4 years. I doubt that you'll receive a reply. Please look at the post dates of dead threads to get an idea of whether or not you'll receive an answer.

Let your other thread on this same sort of problem work for you. Thanks.

 

·
Registered
Joined
·
6 Posts
Well i sent this first. And honestly who cares how long ago this was. If they see it they might reply. Or someone might see it.i understand my other thread is there but I didn't decide to create a thread til after writing this. Thank you for the help
 
1 - 9 of 9 Posts
Top