Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 11 of 11 Posts

·
Registered
2003 cts
Joined
·
6 Posts
Discussion Starter · #1 ·
Initially it started to idol rough. Checked the error code and was a spark plug miss fire at 3. Decided it would be best to replace both coil packs and all six spark plugs. When I pulled up the coil pack the spark plugs were full of oil on both sides. So I figured valve cover gasket. Replaced those and cleaned the oil up as much as possible. Put everything back together. Started car and it won’t stay running without giving it gas and it sounds like air is leaking somewhere. I think it is coming from the black part on top of the intake manifold. However I am not sure. What are my next steps...i had to disconnect the gas line and and some antifreeze leaked out. Could air in the system cause this? Obviously I am not a mechanic. Just trying to fix my favorite car without the large bill.
 

·
Registered
2007 CTS 2.7L
Joined
·
550 Posts
When I did my spark plugs and moved stuff around, one of my soft vacuum lines came off and one of the vacuum hard lines cracked. I had to track down the hard line one as it was near a connector, but under it. I had to just run the car, open the hood and listen.

DISCLAIMER: This is not just because your user name is "Jennifer2004", this goes for anyone out there if you have long hair. When getting into a running engine bay of a car, BE SURE to tie back any long hair and stuff it in the back of your shirt. No dangling jewelry, either. Don't even wear it.
 

·
Registered
2007 CTS 3.6 >137k miles
Joined
·
965 Posts
As you try to locate the leak, try moving the vacuum hoses/lines around and listen for changes in the pitch/intensity. Anything that changes the sound is a good place to start looking for cracks, damage, etc.
 

·
Registered
2003 cts
Joined
·
6 Posts
Discussion Starter · #6 ·
So I think I found the leaks...the pcv adapter seal and the pcv o rings aaand one of the ventilation hoses was basically disintegrated. I found some gaskets already and I am going to have to be a little creative finding a hose since the original one has been discontinued....
 

·
Registered
2007 CTS 2.7L
Joined
·
550 Posts
I got vacuum hose (or high pressure fuel line) from the local parts store from their bulk in the back for cheap. just size it up for the broken piece and have them cut the length you need. I have done that for may vehicles and holds up perfectly.
 

·
Registered
2003 cts
Joined
·
6 Posts
Discussion Starter · #10 ·
Everything was installed and it was running better than before until this morning when it shut off while I was driving and had a message pop up that said start disabled remove key. I think it is probably just a loose wire. I’ll go through and check my connections. I see there was another thread on this very issue so it seems like it happens.
 
1 - 11 of 11 Posts
Top