Cadillac Owners Forum banner

1 - 18 of 18 Posts

·
Registered
01 Deville, 02 Escalade
Joined
·
12 Posts
Discussion Starter #1
02 Escalade-Service Stability System light, tow/haul & stabilitrak buttons don't work

Hey guys, got a few questions about the Escalade that my wife and I just picked up last month (to replace our totalled 01 Tahoe.) Really loving the truck, that 6.0 really scoots! And the ride, very comfortable! :) But anyways, it did come with a couple problems (which is why we got it so cheap.) It's an 02 awd base, with 100,000 miles. The prior owner said the Service Stability System light has been on the whole time he's owned it (3-4 years.) It seems to ride and corner great though, so I'm guessing maybe it's just a bad sensor or connection somewhere? The shocks and compressor seem to work fine, as far as I can tell. Haven't really had any time to check it out much, though (been pretty cold here in Nebraska, but getting better! Plus, we've got 2 daughters, one is 1 1/2 and the other is 4 months old, so I don't get much garage time anymore! lol) I've got one of those cheapie $50 code scanners from walmart, haven't used it yet on the Escalade, but I'm assuming it wouldn't read codes for the suspension. Maybe taking it to Autozone and having them pull the codes might tell me what to look for?

Also, I noticed the tow/haul button doesn't seem to work (I've owned a few silverados and a tahoe, so I know when you press it an indicator light on the gauge cluster comes on, and it'll shift differently.) I've tried it a few times and so far, nothing. Also, the button on the dash that turns the Stabilitrak on and off doesn't seem to work (at least that I've noticed.) Would all these problems possibly be related to eachother? Just thought I'd see if anyone on here had some info I could use, or has been through similar problems (I don't want to start buying parts and replacing things that are working fine, with two babies the ole wallet is a lot lighter anymore!) lol

Other than that, and a hail damaged hood (which I'll get to eventually, I used to do autobody on the side), we love this truck! :)
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
RoadrunnerRod said:
Hey guys, got a few questions about the Escalade that my wife and I just picked up last month (to replace our totalled 01 Tahoe.) Really loving the truck, that 6.0 really scoots! And the ride, very comfortable! :) But anyways, it did come with a couple problems (which is why we got it so cheap.) It's an 02 awd base, with 100,000 miles. The prior owner said the Service Stability System light has been on the whole time he's owned it (3-4 years.) It seems to ride and corner great though, so I'm guessing maybe it's just a bad sensor or connection somewhere? The shocks and compressor seem to work fine, as far as I can tell. Haven't really had any time to check it out much, though (been pretty cold here in Nebraska, but getting better! Plus, we've got 2 daughters, one is 1 1/2 and the other is 4 months old, so I don't get much garage time anymore! lol) I've got one of those cheapie $50 code scanners from walmart, haven't used it yet on the Escalade, but I'm assuming it wouldn't read codes for the suspension. Maybe taking it to Autozone and having them pull the codes might tell me what to look for?

Also, I noticed the tow/haul button doesn't seem to work (I've owned a few silverados and a tahoe, so I know when you press it an indicator light on the gauge cluster comes on, and it'll shift differently.) I've tried it a few times and so far, nothing. Also, the button on the dash that turns the Stabilitrak on and off doesn't seem to work (at least that I've noticed.) Would all these problems possibly be related to eachother? Just thought I'd see if anyone on here had some info I could use, or has been through similar problems (I don't want to start buying parts and replacing things that are working fine, with two babies the ole wallet is a lot lighter anymore!) lol

Other than that, and a hail damaged hood (which I'll get to eventually, I used to do autobody on the side), we love this truck! :)
The service stability system message is because of a wheel speed sensor
Not sure on the tow/haul button but I would check the fuses before doing anything that has to do with electrical
 

·
Registered
01 Deville, 02 Escalade
Joined
·
12 Posts
Discussion Starter #3
Re: 02 Escalade-Service Stability System light, tow/haul & stabilitrak buttons don't

Well, just noticed another problem. Went out to pick up the mail, and then afterwards I grabbed my code scanner and plugged it into the escalade. It wouldn't light up or anything! Figured maybe the scanner broke, so I plugged it into my Ford Ranger, but it worked just fine on there. Looked up a few things about the scanner port and it said it could be just a fuse blown or something... guess I'll have to check that out, too, when I get some more time! lol Man, I hate electrical problems :(
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
RoadrunnerRod said:
Well, just noticed another problem. Went out to pick up the mail, and then afterwards I grabbed my code scanner and plugged it into the escalade. It wouldn't light up or anything! Figured maybe the scanner broke, so I plugged it into my Ford Ranger, but it worked just fine on there. Looked up a few things about the scanner port and it said it could be just a fuse blown or something... guess I'll have to check that out, too, when I get some more time! lol Man, I hate electrical problems :(
Check the cigar fuse in the under hood fuse box maybe its blown(it works that) if the power outlets has a coin in one then there is the reason for the obd port not working
 

·
Registered
01 Deville, 02 Escalade
Joined
·
12 Posts
Discussion Starter #5
Re: 02 Escalade-Service Stability System light, tow/haul & stabilitrak buttons don't

Thanks for the tip... checked all the power outlets, no coins or anything. Popped the hood and checked the fuse box... the cigar fuse was blown! Replaced it with a good one and now the scanner port works! Had to run back inside the house since it's time to feed our 4 month old, but at least one problem got fixed on the Escalade! :)
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
RoadrunnerRod said:
Thanks for the tip... checked all the power outlets, no coins or anything. Popped the hood and checked the fuse box... the cigar fuse was blown! Replaced it with a good one and now the scanner port works! Had to run back inside the house since it's time to feed our 4 month old, but at least one problem got fixed on the Escalade! :)
That's great news keep us posted when you get the codes
 

·
Registered
01 Deville, 02 Escalade
Joined
·
12 Posts
Discussion Starter #7
Re: 02 Escalade-Service Stability System light, tow/haul & stabilitrak buttons don't

Well, my cheapie scanner didn't pull any codes (I believe it only reads engine problem codes, which is also good, meaning at least engine wise this truck is fine!) Just got the babies to sleep and went for a little drive, noticed that if I start the Escalade and press the Stabilitrak off button it does turn off, but if I turn it back on and drive a little that Service Stability System light comes back on. Also noticed that if I come to a stop and shift down to first gear I'm able to press the Tow/Haul button and that works! But strangely I can't turn it back off, unless I come to a stop again and shift back down to first and press it again. Is this how all Escalades are? I know on our Tahoe and my former Silverados I could turn Tow/Haul on and off anytime, in any gear... kinda weird, but at least it basically works if anything :)
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
RoadrunnerRod said:
Well, my cheapie scanner didn't pull any codes (I believe it only reads engine problem codes, which is also good, meaning at least engine wise this truck is fine!) Just got the babies to sleep and went for a little drive, noticed that if I start the Escalade and press the Stabilitrak off button it does turn off, but if I turn it back on and drive a little that Service Stability System light comes back on. Also noticed that if I come to a stop and shift down to first gear I'm able to press the Tow/Haul button and that works! But strangely I can't turn it back off, unless I come to a stop again and shift back down to first and press it again. Is this how all Escalades are? I know on our Tahoe and my former Silverados I could turn Tow/Haul on and off anytime, in any gear... kinda weird, but at least it basically works if anything :)
Sounds like something isn't right
The service stability system message is possibly a wheel sensor

The tow haul mode button is not normal as on my 03 you can turn it on and off regardless of gear position(I have the service manual for ours trucks and will look into the wiring for that to see what it goes to as it seems that it is tied into the transmission along with the suspension system(don't ask long story) and the power steering system
 

·
Registered
2002 Escalade
Joined
·
2 Posts
Re: 02 Escalade-Service Stability System light, tow/haul & stabilitrak buttons don't

Your Tow/Haul button should work no matter what gear you are in, moving or not, my 02 escalade does. You probably have a bad wire in the gear shifter that makes connection when you pull it down into first gear. I changed the gear shift handle on my brothers 02 durmax and it fixed his not working button. not to difficult, same setup.

On the service stability part, my 02 escalade has the light come on also. The compressor comes on for a few seconds after reaching 5 mph, then it pauses for a few seconds then back on for a few seconds then off, then the light immediatly come on, same sequence without fail everytime i drive. to clear the light i turn the engine of and then back on. See if this the same as yours, and any help will be appreciated by me also.
 

·
2002 ESV
Joined
·
8 Posts
Resurrect an old post.. I just got a 2002. The SSS light is on and I can disable the stabilitrak system. How would I know why the light is on? I saw someone mention the wheel speed sensor, how do I know if that is bad?
 

·
Registered
2004 ESV
Joined
·
551 Posts
Stabilitrak could also be triggered via the yaw sensor and/or the steering wheel position sensor. In my 04 ESV, the yaw sensor is located under the passenger seat. Steering wheel position sensor lives in the void of the steering column bushing. I think the yaw sensor is located behind the second row in the short wheelbase variants.

I think if you had wheel speed sensor issues, traction control would throw messages first.
 

·
2002 ESV
Joined
·
8 Posts
Stabilitrak could also be triggered via the yaw sensor and/or the steering wheel position sensor. In my 04 ESV, the yaw sensor is located under the passenger seat. Steering wheel position sensor lives in the void of the steering column bushing. I think the yaw sensor is located behind the second row in the short wheelbase variants.

I think if you had wheel speed sensor issues, traction control would throw messages first.
Thanks I'll go during some digging and see what I can find
 

·
2002 ESV
Joined
·
8 Posts
just wondering if you figured anything out to fix the problem ive got the same issues thanks
I haven’t. The only way to get the code read is go to a GM, Cadillac etc dealership and pay them to read the code.
Although If it is the air ride suspension, and you don’t want to fix it, there’s a company arnottindustries.com that makes a rear strut that plugs into the auto leveling sensor and tricks the computer to think everything is ok.
 

·
Registered
2004 ESV
Joined
·
551 Posts
If you plan to go with traditional shocks, you don't need anything to trick the ecm. Just a battery disconnect and pull the rtd 30a fuse, and the stand alone relay next to the fuse box in the engine bay.

I am assuming the fuses are the same for the 02 and my 04 as it pertains to the air suspension.
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,065 Posts
Any local parts store can scan the car and give you a code printout. Or you can buy your own OBD-II scanner - they plug into the OBD emissions test port near the steering column, usually just under the lower edge of the dash panel.

Bookmark this - use it to decipher found Current and History codes -


Want to watch some gauges in real time and also have a scanner? Look into www.scangauge.com or www.ultra-gauge.com
 

·
Registered
2004 ESV
Joined
·
551 Posts
Any local parts store can scan the car and give you a code printout. Or you can buy your own OBD-II scanner - they plug into the OBD emissions test port near the steering column, usually just under the lower edge of the dash panel.

Bookmark this - use it to decipher found Current and History codes -


Want to watch some gauges in real time and also have a scanner? Look into www.scangauge.com or www.ultra-gauge.com
A call to a parts store would be beneficial, as most of their scanners only read engine codes. The other systems (ABS, SRS, Suspension) will not be read. Same with a lot of the cheap bluetooth dongles on Amazon. Best to make sure the scanner being used can read all vehicle modules.
 

·
Premium Member
2004 Escalade 6.0
Joined
·
1,113 Posts
1 - 18 of 18 Posts
Top