Cadillac Owners Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. STS Forum - 2005-2012
    Hello! My problem is I’m seeing Reduced engine power come up on my dash and my car will not start now. The gas pedal does nothing when I try to start it so I can rev it up to keep an idle. It’s so close to starting but just won’t and I can’t help it with the pedal at all. So I researched and...
  2. ATS General Discussion Forum
    so long story short, I installed the Zzp large throttle body for my 2018 ats 2.0 Issue I encountered 12 hrs after install -knocking from engine -only once, seen steam coming from the hood -rpm sputtering -let off gas, speed stayed constant, rpm went to 0 - virtually 0 rpms when at stop -hard...
  3. 2008-2013 CTS Performance Mods
    Okay so after I did my research about the vmax iceolator, I heard about the vmax ported throttle body. Well now I cant find anyone that sells it. I found basically the same thing on Ebay, some guy by the name of Greg was selling it. But these are not the vmax throttle body's. I was wondering if...
  4. CTS First Generation Forum - 2003-2007
    What's the small hose coming from the bottom of the throttle body then connecting to a thin plastic line going back between the upper and lower intake manifold on an '03 3.2? I thought it was a vacuum line but it's dripping antifreeze. I've replaced the hose twice but it still drips. 😕
  5. 2008-2013 CTS General Discussion
    So i have a 09 cts base I was getting engine power reduced and so I cleaned the throttle body put everything back on and I’m still getting p0121 p0221 p0223 p2119 p0496 all connectors are fine but I heard about a tb reset but can’t find any info on it. Can anyone help???
1-5 of 5 Results
Top