Cadillac Owners Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-7 of 7 Results
  1. ATS General Discussion Forum
    Background: Bought a 2014 Cadillac ATS 2.0T in Feb with 98k miles. First hot day in the spring, I noticed the AC wasn't working and just blowing out hot air. Refilled with Freon and compressor kicked on and AC started working again. Fast forward a few months and a move to Austin, TX, on a...
  2. 2008-2013 CTS General Discussion
    I recently had my left front wheel speed sensor go bad. When that happened, multiple warnings turned on (abs, traction control, StabiliTrak, etc.) When I replaced the sensor, they all went away except the "Service StabiliTrak" warning. I don't see any signs that any of the other parts of the...
  3. 2008-2013 CTS General Discussion
    I have a 2011 CTS with service brake assist, service stabilitrak, and service traction control in the DIC. ABS and TC lights are on, but NO CHECK ENGINE LIGHT is on. I have an OBD2 sensor reader, and it’s not throwing any codes. The car has seemed to be riding “loose” as I’ve gotten into...
  4. Escalade, EXT and ESV Forum - 1999-2006
    Hi All, New to the forum. New owner of 2002 Escalade Ext. I've been reading through the owner's manual and it seems like some lights/messages that should turn up when the key is in RUN or when engine is running are not working. Air Bag Readiness Light does not flash when I turn the key to...
  5. 2008-2013 CTS General Discussion
    I have a 2500RMS amp, with a 3 farad capacitor, & if I turn my system up while driving, occasionally my DIC pops up with “stabilitrak off” for half a second, without putting my car in limp. Seems to drive fine during & immediately after. Brand new AGM battery put in about 3 months ago. Any idea...
  6. Escalade, EXT and ESV Forum - 2007-2014
    Hello I'm new to this forum. I've read a lot of posts about similar issues but nothing that was exactly what I was dealing with. I had my rear driver shock airbag blow which was a problem on its own. I have replaced it and now the compressor stays running non stop. Both airbags hold air but the...
  7. XT5 First Generation Forum - 2017+
    Here is the situation, the vehicle has been parked for about a month and a few days, Today morning, started the vehicle, starts normally, all kinds of yellow light signals show up, including transmission, a message pops up stating Stabilitrak issues, I shift to drive, does not drive, I feel as...
1-7 of 7 Results
Top