Cadillac Owners Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-4 of 4 Results
  1. Northstar Engines and System Technical Discussion
    I just finished both valve covers today 11/27/21 at 56k miles. When I was having a hard time with the passenger side I decided to do some more searching around on the forum for info and found this post here by Neutrocuted which helped me out a ton although some of his info did not apply to me...
  2. STS Forum - 2005-2012
    Hi has anyone else had a problem with their lh2 Northstar pinging? It doesn't matter what gas I use, I've been running 93 octane and I still get a ping, and no check engine light at all, or codes? It just started out of the blue. Right after I had power steering pump replaced. Thank you for any...
  3. STS Forum - 2005-2012
    The white whale I have been chasing for a few years. My LH2 (~65k miles) has high LTFT (over 20%) on both banks during high engine vacuum, though bank 2 is higher and thus occasionally (maybe every four months) sets a P0174 after extended driving. At cruise or acceleration, LTFT are above 0% and...
  4. Northstar Engines and System Technical Discussion
    As a result of driving on LPG, I experienced compression leakage during cold run on cyl. #1. Both the inlet valves leaked as a result of burnt valves/seats due to lean mixture burning in cyl.#1 causing a higher combustion temperature. The lean mixture was a result of bleed air being mixed at the...
1-4 of 4 Results
Top