Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of August's Ride of the Month Challenge!

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 499 Results
  1. 2004-2007 CTS-V Performance Mods
    I have a cts v with an ls2 motor and it is just over 1000 miles since rebuild. I found metal shavings in my oil at 500 miles and less at 1000 but they were still there. Is this a normal thing to happen and should I be worried? Everything in the engine is new (bearings included) except the crank...
  2. FWD DeVille 1985-2005, Fleetwood, and 60 Special
    Like pictured above I'm thinking this will work but I didn't know if there was a better spot or way to get power right from a source
  3. FWD DeVille 1985-2005, Fleetwood, and 60 Special
    Weird noise when turning just the key to my car, just started happening. It’s not having problems starting, that’s just the first click of the on position. Link
  4. RWD DeVille/Fleetwood, Brougham 19xx-1996
    I heard the air pump run about a day ago but it hasn't gone back down, it's full lifted up. How do I reset it or make it return to normal non-erect height?
  5. SRX 2nd Generation Forum - 2010-2016
    I could really use some help, about a week ago we got into trying to find our downshift solenoid on my 2010 srx and we got into the TCM underneath of the car, we disconnected everything prior to doing this like the battery and drained the transmission fluid. Finally today we decided since we...
  6. CTS First Generation Forum - 2003-2007
    Had a 2003 cts start to go rough idle, it’s perfectly fine when running but starts to kinda kick back when slowing down. Don’t have a scanner either but used a friends to see and it was the 4th cylinder. I was wondering if anyone might’ve run into this too. Also sorry just wondering if there’s a...
  7. RWD DeVille/Fleetwood, Brougham 19xx-1996
    Hello, thanks for taking the time to read this. I’m Ben and I’m working on a vehicle 1-2 my senior haha. My brother has a 1990 Cadillac brougham 5.0L rwd four door with soft top (silver on silver, gunmetal accents, spoke rims). Our good friend bought this for his Hispanic wife who never was...
  8. 2008-2013 CTS General Discussion
    So I have owned my Cadillac CTS for about two years now. Well in the past year I have been having crazy electrical issues. While the vehicle is on you can watch the voltage take huge dips dropping from 14 all the way down to 11 and even 10 volts. You can watch the headlights and illuminated...
  9. ATS General Discussion Forum
    So my cue screen recently stopped working on my '13 ATS. Not the actual screen itself but the touchscreen aspect has gone out. Has anyone replaced this before? I know its a common issue with the cue screens but is there an option to just replace the screen/touch aspect without replacing the...
  10. CTS First Generation Forum - 2003-2007
    Moderator edit: Duplicate thread from incorrect forum merged here. Sub. I was cruising down the highway took my exit and it just shut off, no sound nothing power was there till i kept trying to crank it, got it towed home, replace the alternator and battery this was the first try but just...
  11. Escalade, EXT and ESV Forum - 1999-2006
    Hi all I have a 2005 escalade base model almost 160k miles today I made a left turn from a stop the truck made a noise and felt like the engine revved high and didn't move for a moment then started moving but kind of slow so I found the 1st driveway I could and pulled in backed out and started...
  12. STS Forum - 2005-2012
    Hello everyone, I have a 2008 STS RWD 4.6 V8, the engine harness got snagged and ripped out of the bottom and now it’s ripped In pieces. I’m wanting to know if I can interchange the harness with another year from a pull-a-parts, Thanks EDIT: For anyone looking at this post at a later date or...
  13. CTS First Generation Forum - 2003-2007
    To start I have a 2006 Cadillac CTS. I guess I'll explain the problem first before anything else. It doesn't matter what weather conditions I'm driving in, the speakers always seems to cut out for 1-5 seconds then come back on. This is very annoying because I can't even make it through a single...
  14. ATS General Discussion Forum
    I have a 2013 ats 2.0t and my passenger side tail light is only partially working.. my blinker works and my brake light works but I have no running light! I can’t find a fuse or relay for it.. anyone have any suggestions?
  15. Seville and Eldorado Forum
    I just bought a 1995 cadillac seville SLS and with 70,000 miles on it. The information button on the information panel won't allow me to check anything on it, because I don't think it works( Gas estimation doesn't work either but display off/on button does on same panel). The airbag light is on...
  16. 2008-2013 CTS General Discussion
    Hello all! I have a 2010 CTS 3.0 V6. My coolant temperature sensor is acting up on me. I have googled and have not had much luck. So I’m looking for the location and some replacement tips if anyone has any! Thanks in advance!
  17. SRX 1st Generation Forum - 2004-2009
    I am trying to order a new radiator for my 07 SRX4 4.6l v8. Well I have 2 options. The only thing from stopping me is if mine is the trailer package or not. I don't want to waste time and money ordering the wrong one. This is my first Cadillac. I have only owed bmws. So this has me feeling dumb...
  18. 2014-2019 CTS General Discussion
    Hello! I need some advice. Took my 2012 CTS in for routine oil change and they said my right rear axle seal was leaking. Quoted 450. The part is 16.00. I had a different mechanic look at it and said it was "slinging grease" and that it's the whole axle. Quoted me 500. Called the dealership and...
  19. ATS General Discussion Forum
    Has anyone else had this code occur with no symptoms arising? I have a '13 ATS 2.0L Luxury that threw this code last night. I havent been able to discover what it might be but ive read its rare to have no symptoms. Does anyone have some simple solutions I could check before taking it somewhere...
  20. Seville and Eldorado Forum
    So my headlights suggested message will come on when it rains but not at night. and if i do turn my lights on at night the dash light stay at full brightness and i can not dim them and the lights for the buttons on the ac, radio, and buttons on side of dash do not turn on
1-20 of 499 Results
Top