Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 21 Results
  1. Escalade, EXT and ESV Forum - 2007-2014
    Today I went into a restaurant for lunch and everything was fine. I went to leave and my truck was completely dead. No click, no chime, and no lights would work. I was able to get it started after calling roadside assistance, they used a jump box. It dies immediately after he removed the cables...
  2. Seville and Eldorado Forum
    HELP..... Ok so I got a 98 Seville sts, 1 previous owner and only 80,000 miles. Before I put 75 miles on it the 2nd/back CPU burnt up, cost about $1200 and a month to replace!! The MF drove like a dream for about year and a half then one night I got off work and started it up and the battery...
  3. ATS General Discussion Forum
    Hi 🙋‍♀️ thank you for the opportunity to ask these questions to solicit some help. I’m really stressing out and I’m hoping this code is nothing major. I have 2 finals I need to cram for and I’m hoping I can wait 3 weeks? Or if I need to act now? Error Codes: P0700 $07E8 Please see attached...
  4. STS Forum - 2005-2012
    So i recently bought a 2005 STS and one thing i noticed quickly was that the radio does not work at all, but i would always hear a hum coming from it even when the car was off. So i took out the radio and found out that a plug/wire has been completely ripped out and im not sure what it is...
  5. 2004-2007 CTS-V General Discussion
    Hello I am having a strange no start issue and am seeking any advice or knowledge that may assist me in fixing it as I have not found much that has been helpful on this topic so far (2006 CTS V). My symptoms are that when I put the key in the ignition and turn it to start it does nothing you...
  6. Classic Cadillac Forum
    I need help identifying what car these hubcaps belong to! Any ideas? The whole hubcap is 10" and the inner rim that snaps into the wheel is 7.5" if that helps?
  7. Northstar Engines and System Technical Discussion
    I think this is the regulator calculator harness but there is there is other wires coming out of it that are clipped there is a Brown wire a small black Wire a red wire which I assume goes to the regulator then there is and there is a fat green wire and a fat black wire that looks like it has a...
  8. Escalade, EXT and ESV Forum - 1999-2006
    Hey everyone, this is my first time posting after looking at the forums for a few months, and now i have a question for anyone who can help. i recently installed some red LEDs in my gauge cluster, but it would seem that i shorted something by touching one of the leds to something, and my...
  9. 2008-2013 CTS General Discussion
    I own a 09 CTS4 DI ,AWD. I purchased the car well below owners asking price knowing it had some mechanical issues that needed attention. Other then the normal plugs,coils,filters an some idler pulleys nothing major an a drive shaft. I run No ethonal gas an royal purple full synthetic oil. An...
  10. 2008-2013 CTS General Discussion
    I change the capture and bearing and my codes become,what the probleme
  11. XTS Forum- 2013-2019 Including XTS V-Sport
    Hello all, I was merging off I-95 on an off ramp, hit a Raccoon or Opossum at around ~80mph, he obliterated my front DRL or LED Fog Lamp, whatever it’s called. The light housing is busted open, and hanging inside the bumper assembly. Not only that broke, as my left turn signal (wasn’t hit)...
  12. Northstar Engines and System Technical Discussion
    I have a 96 eldorado with 98k miles and last week a line connecting to the radiator that goes straight down and in right above the oil filter. I’ve ordered 2 high pressure oil hoses but none have worked now I thought about it and I’m thinking possibly power steering line? It’s on the passenger...
  13. ATS General Discussion Forum
    Owner of a 2015 Cadillac ATS 2.0t LTG rwd I believe it’s a piston again, changed spark plugs egnition coils, vvt solenoids, and fuel injectors absolutely nothing helps getting a cylinder 4 misfire engine running rough not a lot of power jerks when braking this is the 4th time struggling...
  14. STS Forum - 2005-2012
    Okay guys I hope this is a quick easy question to answer. Im replacing my timing chain and im at the point that i need to remove the valve covers. I remember when i replaced the valve cover gaskets, the driver side valve cover has plenty of room to come off and back on. However the passenger...
  15. Escalade, EXT and ESV Forum - 1999-2006
    Hi all I have a 2005 escalade base model almost 160k miles today I made a left turn from a stop the truck made a noise and felt like the engine revved high and didn't move for a moment then started moving but kind of slow so I found the 1st driveway I could and pulled in backed out and started...
  16. ATS General Discussion Forum
    It’s been over a month I changed my battery out and my instrument cluster (I believe that is what it is called has gone out) I’m not sure if it was a fuse that’s been blown or what but I don’t know which fuses to check because I don’t understand the diagram . The car is drivable. Has anyone...
  17. XT5 First Generation Forum - 2017+
    Hey everyone! I have to replace my front driver side hub assembly on my 2017 3.6L Cadillac XT5 Luxury immediately. I noticed a loud grinding noise while driving down the highway the other day, put my car in neutral and was able to determine that it was the driver side wheel bearing. First...
  18. STS Forum - 2005-2012
    Hey guys, I’m working with an 07 Cadillac STS 3.6 L , I’m trying to decide if there is any kits or way to put a turbo on this engine without it being a stress. I just got this car from it being sitting for 3 years . A tranny line blew out the radiator so I’m upgrading the radiator , tranny...
  19. Seville and Eldorado Forum
    Just bought this car the stupid e048 Code comes on 20 miles in. My e048 code is solved but now i have an even bigger issue than i started with. Trying to get the erg valve off I really screwed the pooch and moved the tps around and had unscrewed it. I'm assuming it is so out of whack that it is...
  20. SRX 2nd Generation Forum - 2010-2016
    Hello Everyone, I recently moved to Canada. I have a 2010 SRX that I purchased from USA. Everything in Canada is in km/hr. I know I can switch the digital speedometer to km/hr but the needle still works in mph. I was thinking if I just buy a used instrument cluster which is in km/hr and plug and...
1-20 of 21 Results
Top