Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of August's Ride of the Month Challenge!

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-4 of 4 Results
  1. ATS General Discussion Forum
    i tried to jump start my girlfriends car and hooked up the ground incorrectly. i lost power to my gauge cluster, radio, a/c controls and 12v charger. ive checked several fuses and cant seem to find any that are burned out. ive disconnected the battery to reset the system and nothing. car turns...
  2. STS Forum - 2005-2012
    What's up everyone My STS just threw a P0650 code. Looks to be some sort of check engine light malfunction. Easy fix would be to just replace the bulb and hope it's not a wiring issue. With that being said, has anybody on here removed the gauge cluster before? I know GM cars can be pretty...
  3. Escalade, EXT and ESV Forum - 1999-2006
    Hey everyone, this is my first time posting after looking at the forums for a few months, and now i have a question for anyone who can help. i recently installed some red LEDs in my gauge cluster, but it would seem that i shorted something by touching one of the leds to something, and my...
  4. DTS Forum - 2006-2011
    Hi, I'm new here, I just recently bought a 2007 Cadillac DTS. I saw pictures of different colored gauge cluster lights and decided I wanted to change mine to purple. I found some on amazon that claimed to work and had good reviews and I went to swap the lights, and there aren't any lights to...
1-4 of 4 Results
Top