Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 28 Results
  1. 2008-2013 CTS General Discussion
    My cruise control goes on properly, but at any random time can disengage and will not reingage. It usually happens after 1-3 hours of driving, but sometimes I can go longer. The yellow switch light to indicate the system is on and always stays lit, but the green cruise indicator in the...
  2. XTS Forum- 2013-2019 Including XTS V-Sport
    2017 XTS. After driving the vehicle for 30-45mins yesterday with no issues of any type, pulling into the garage the traction control warning light Came on then went off. When I turned off the car, it lost all power. No lights, couldn’t unlock doors, Unable to open trunk (made getting...
  3. 2004-2007 CTS-V General Discussion
    Hi guys, The title is pretty self explanatory. I have a 2005 CTS-V with a sunroof, and the control switch knob broke off just by bumping it with my backpack when getting in. I managed to kinda stick the knob back on the pin but I would like a new OEM replacement for just the switch/knob, not...
  4. Classic Cadillac Forum
    Hey guys need some serious help again. I previously had replaced a voltage regulator with a solid state one (my mistake, ended up making the system put out 18 volts) so I got a new point style one, exactly the same as the old one, and now my system is putting out nothing. I’ve got proper voltage...
  5. STS Forum - 2005-2012
    So i recently bought a 2005 STS and one thing i noticed quickly was that the radio does not work at all, but i would always hear a hum coming from it even when the car was off. So i took out the radio and found out that a plug/wire has been completely ripped out and im not sure what it is...
  6. STS Forum - 2005-2012
    Hello everyone, A few weeks ago I parked my 2008 Cadillac STS 4.6 RWD. The issues being I lost my RPM response on my clusters and the car ran rough. I always keep a OBD2 scanner in my car so I scanned it. It turned out to be P0336 and set off two knock codes after (P0325, P0328) I reset to see...
  7. XT6 First Generation Forum - 2019+
    Has anyone experienced any electrical problems with their XT6? I was waiting at a stop light and when it turned green I put my foot on the gas and the whole car shutdown. I could not restart the car at all or even put it in neutral to get pushed off the road. The battery connections seem...
  8. FWD DeVille 1985-2005, Fleetwood, and 60 Special
    2005 Deville Base 112k miles. I had a very slow radiator leak that produced hot coolant smell, so I decided to replace the radiator and also the water pump (70k miles on it), which I had done prior in a N* - 2000 Seville STS. The job went as good as can be, nothing of note went wrong, just the...
  9. STS Forum - 2005-2012
    Hello, I’m in the process of an engine wire harness swap. I am almost finished with the swap but I have ran into some issues. The issues relate to the gas pedal and throttlebody. The engine is running rough but is running. I have the codes and will leave them in an attachment for others to look...
  10. Escalade and ESV Forum - 2015-2020
    My dashboard would start flickering on and off out of no where. Recently during the flickering, the vehicle would just turn completely off while driving or at the light. I drive everyday and its occurred about 3x within the last 3 weeks. I'd put it in park and start the vehicle up again and it...
  11. STS Forum - 2005-2012
    Hello everyone, I have a 2008 STS RWD 4.6 V8, the engine harness got snagged and ripped out of the bottom and now it’s ripped In pieces. I’m wanting to know if I can interchange the harness with another year from a pull-a-parts, Thanks EDIT: For anyone looking at this post at a later date or...
  12. DTS Forum - 2006-2011
    Hello all, I've recently been having some issues my 2006 DTS's rear passenger door. The car is a Luxury III trim with heated rear seats, rear lumber support, and Bose Premium Sound w/out navigation. My issue is this; the right rear passenger side door controls for the heated seat and lumbar are...
  13. XTS Forum- 2013-2019 Including XTS V-Sport
    Recently picked up a '16 XTS and shortly after taking ownership the check-engine light came on. Had a friend take a look and he said the error indicated an issue with the cooling fan relay. OK - that's what warranties are for so I headed to the Cadillac dealership to get it diagnosed. Three...
  14. Escalade, EXT and ESV Forum - 2007-2014
    Hello all, I'm currently having an issue with my Escalade that I need help with. I went out one day to leave the house and she wouldn't start, crank but no start. I had three codes pop up on my little scanner, P0121 (Throttle Position Sensor), P1682 (Ignition 1 Switch Circuit 2) and then P1682...
  15. Classic Cadillac Forum
    This spring I went to a buddies house to consult on his kitchen remodel and only moments after having parked he asked me to move to a different spot as I was blocking a driveway his renters had need of. My cadi wouldn’t start. My buddy is mechanically savvy as is his brother who was there...
  16. 2008-2013 CTS General Discussion
    I have a 08 CTS that has issues beyond worth repairing because of the leaking damage, the electrical damage is something way above my head. I’m looking to sell as is. It turns on but driving it is not a option like it is now. I just can’t invest anymore time or money to figure out what’s going...
  17. STS Forum - 2005-2012
    I have a 2009 STS, recently I have encountered problems with the passengers side signal light not working. Naturally, my first thought once the signal light stopped working was to replace the bulb. I got a new bulb and the new bulb didn't work, and turns out the old bulb still worked. I then...
  18. Escalade, EXT and ESV Forum - 2007-2014
    My 2008 Escalade is having major electrical issues, never had a problem before. Here’s what’s going on, long story. I drive about 350 miles up north with no issues, it was -20f up there but I plugged in my heater, next day Escalade barely started. I let it warm up then drove 350 miles back home...
  19. 2004-2007 CTS-V Performance Mods
    Just bought a 2005 CTS-V and was curious of if it was possible to retrofit a C5’s HUD (heads up display) in it?
  20. Seville and Eldorado Forum
    Hey everyone, Discovered a week ago that my left tail light was out and found out it was the fuse. Replaced it and thought all was fine, but the thing just keeps blowing (LT park). The third lamp and the taillights work when using a turn signal or the brakes, but at night the running light is...
1-20 of 28 Results
Top