Cadillac Owners Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 192 Results
  1. 2008-2013 CTS General Discussion
    Sorry, but this is a bit longwinded... My daughter has a 2008 CTS and has owned it for 3+ years with no issues until now. So about 4 months ago my daughter called and said she ran out of gas. I bring a 5 gallon can and put it in there and it wouldn't start at first. It then started but ran REAL...
  2. CTS First Generation Forum - 2003-2007
    I have a 2003 cts with a 3.2 has 120,000 on it and is Vin N. The coolant temp sensor, air intake sensor, and camshaft position sensor wont work they all read high voltage. I replaced all the sensors as well as the ECM and that didn't help so I dug into the wiring diagram and discovered they all...
  3. FWD DeVille 1985-2005, Fleetwood, and 60 Special
    I'll start with a little history on this car, it's a 1990 FWD Sedan Deville D'Elegance edition, only 110k miles. I bought it about a year ago and I've been slowly tracking down all the issues it has. Full cooling system rebuild Tightened some loose A/C fittings and it's already converted to...
  4. 2008-2013 CTS General Discussion
    Is there any way I can figure out if it is the wiring harness It would make it lose communication with the ECM or anything else I can try before this dealer keeps doing parts at it. They say the ECM was fried when I touched the cables together, I hope it isn't a fuse. Now my car is there and...
  5. CTS First Generation Forum - 2003-2007
    Really hoping someone can help. My 2004 CTS (3.6L v6) Starts with the key intermittently. When it doesn’t start if I pull up (sort of wiggle, but not pull out all the way) the starter relay fuse, the car will crank and start. The previous owner replaced the PCM/ECM (whatever it’s called) and...
  6. CTS First Generation Forum - 2003-2007
    Hello, I've browsed many posts on this forum and I believe my ecm may be bad. The next thing I intend to check is the grounds under the drivers seat as I've seen those are known to come loose. 2003 cts base. 195k miles. Excellent condition mechanically and cosmetically. About a year ago my...
  7. 2004-2007 CTS-V General Discussion
    I recently purchased an 05 cts-v and it has been missing especially noticeably in 6th gear running low rpms and occasionally when accelerating. The check engine light does not come on, I tried disconnecting the maf which made it worse if anything, that also did not bring the check engine light...
  8. 2008-2013 CTS General Discussion
    I need the ground wire locations for a 2008 CTS4 it has 3.6 V6 engine. I just had trans rebuilt and after getting it back, I’m now having random electronics issues that come and go but my cluster has completely stopped working and my ECM/PCM will not communicate. So I’m wondering if it’s a...
  9. CTS First Generation Forum - 2003-2007
    Since purchasing my cts I've replaced all 6 spark plugs, ignition coils, fuel injectors, fuel filter, multiple cam sensors, crank sensor, the evap purge cannister, all of my air lines where I've also installed an aftermarket oil catch can (a must have), the battery, alternator, thermostat and...
  10. CTS First Generation Forum - 2003-2007
    Hello, this is a guide on how I replaced the ECM on my '05 CTS. In total it only took me 30 mins. If you haven't bought one yet stay away from Flagship One and All Computer Resources. Step 1: Make sure you disconnect the negative battery cable before starting, the bolt size is 8mm/5/16" Step...
  11. CTS First Generation Forum - 2003-2007
    I had a family member give me a 2005 CTS 3.6, the motor in it had quite a few problems but it still drove (pretty rough) I drove it across town to my house and put it in the garage, after a few days I went out to mess with it, but the "service theft system" came on and it wouldn't do...
  12. SRX 2nd Generation Forum - 2010-2016
    This thread is written to help others how I fixed my problem. I hope this to be a live thread with lots of info charing the brainstorming. If you can shed more light into this situation feel free to do so as I dont see much info on how to solve these issues on the internet. they have solutions...
  13. SRX 2nd Generation Forum - 2010-2016
    I cannot get the car to crank either (I have the antitheft lock icon come up when I try to start it). The dash lights up and I get the check engine so I read the codes and I get the U0100 code for ECM no communication. I looked around and it seems like the CAN bus might not be communicating. I...
  14. STS Forum - 2005-2012
    The car is clearly misfiring and throwing codes P0203 & P0303. After replacing the #3 injector nothing has changed. Same codes and running terrible. The wiring harness looked good, so I'm thinking ECM replacement? I've seen that there is a reprogramming procedure to teach the new module and the...
  15. CTS First Generation Forum - 2003-2007
    Ok so the car has been misfiring for some time and pulled the codes off and it says injector circuit 2 open. So I replaced the injector. Started the car it ran fine for couple of miles and started misfiring again with same code. So I thought ok maybe fuel injector wiring hareness is bad so I...
  16. Catera and Cimarron
    We recently replaced our ECM with a newly programmed one from Flagship. Our previous one was fried when it accidentally got to close to the battery (battery arced and fried it) . We programmed the key. When we turn it on, it catches for a split second, then doesn't fully start. We thought it's...
  17. CTS First Generation Forum - 2003-2007
    I replaced the ECM in my 2004 CTS. Went to do the key relearn and the instructions say "turn the key to on position, security light will come on and stay on..." My security light won't stay on, it just keeps flashing.. what am I doing wrong??
  18. 2004-2007 CTS-V General Discussion
    I need some help. I purchased ichpen's 06 w4m ecm for my 07. After installing I reconnected the battery and now neighter key will start the car. The nav displays a message saying "starting disabled - remove key". Obviously this is security related. So far, everything I've read indicates...
  19. RWD DeVille/Fleetwood, Brougham 19xx-1996
    I'm looking for a 1983 Deville 4100 ECM. I just bought back my first car from I was 16. Strange how I had just said I regretted getting rid of it, and then I found it FS on Craigslist. Anyways. I bought it and it refuses to start. It cranks, and will just about fire if you hold the pedal...
  20. 2008-2013 CTS General Discussion
    Just installed my new 9500ix using Mike's Mount. At $22.00 w/shipping it's a true bargain compared with other mounts at more than twice the cost! Using an Invisicord kit total install time was about 15 minutes. Only snag was removing the cover from the wiring harness behind the mirror, took a...
1-20 of 192 Results
Top