Cadillac Owners Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. STS Forum - 2005-2012
    Dear All! I’m new here. Sorry for my not-so-good English skills... Anyway here comes a few questions from Finland about the Cadillac 6 six-disk radio & Navi unit. I bought STS 2006 car and after the bad quality battery change for the new one. The radio and the screen totally died. The radio...
  2. XTS Forum- 2013-2019 Including XTS V-Sport
    I’ve been without my car for months now, my car has a rough idle, turns off while on at times, I’ve changed the spark plugs, ignition coils a full tune up, oil change…. I’ve come to a wall and I’m stuck. I figured someone has had a problem similar to mine. I literally put it in drive or reverse...
  3. SRX 2nd Generation Forum - 2010-2016
    I have been repairing some body damage on my 2014 Premium SRX for over a year. I have finished the repair, went to start the car and as you would think, the battery is dead. removed the battery and had it check and charged. Now the car will crank but not start. Codes P159F Fuel ecomony mode...
  4. 2004-2007 CTS-V General Discussion
    When I first got car it was driving and turning on fine but after a while car would not turn start but I would let it sit for a while and it would start right up but now it doesn’t even start. I have replaced the battery, starter, starter relay and since car hasn’t start I scanned it and these...
  5. FWD DeVille 1985-2005, Fleetwood, and 60 Special
    I am wondering if any one can give me pointers for my starting issue on my 04’ DeVille. Here and there, mostly when it sits for a little bit, I go to start it and it just cranks and cranks. If I let off the key, and try it again it almost always starts right up. I’m not sure what causes this...
1-5 of 5 Results
Top