Cadillac Owners Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-11 of 11 Results
  1. Escalade, EXT and ESV Forum - 2007-2014
    I have a 07 Escalade that was working well until Recently I had driven for a about a mile and then the car will then shake and slowly die down. When starting the car it will take minutes before doing the same thing. I had got the motor head fixed. Im not to sure. Has a new battery but recently...
  2. 2008-2013 CTS General Discussion
    Trying to test an issue with a relatives 2011 CTS - battery is draining (everything is stock on this car nothing drawing alot of amps). Can someone tell me what the pinout of the 2-wire connector is? I'd like to see if I could give it the right signal/voltage/resistance to engage the charging...
  3. 2008-2013 CTS General Discussion
    So it's 100+ and humid here in Georgia. I drive my 2010 CTS RWD about 300-400 miles a week sometimes more. It has 118k miles. Started working on it about 6 months ago with front wheel bearings and new set of brakes. Regular oil changes etc. Prior to June this year I would drive it mostly on the...
  4. Classic Cadillac Forum
    Hey guys need some serious help again. I previously had replaced a voltage regulator with a solid state one (my mistake, ended up making the system put out 18 volts) so I got a new point style one, exactly the same as the old one, and now my system is putting out nothing. I’ve got proper voltage...
  5. 2014-2019 CTS General Discussion
    Just wanted to help out some people just in case alternator issues come up. I recently have done some research on an alternator issue that I was having. But couldn't find any information on here using the search function and very little on internet. Most or all Cadillacs from 2014-2020 ATS,CTS...
  6. FWD DeVille 1985-2005, Fleetwood, and 60 Special
    Okay, so I've had my DeVille for the better part of 5 years. In the time I've put on just as many alternators. (I almost think I know why though) As I'm getting ready to put on a new one later tonight/tomorrow, I started checking all my fuses. Under the hood there are a few that caught my...
  7. DTS Forum - 2006-2011
    I have a 2009 DTS with 215,000 miles... About a month ago my Service Charging System light on my dashboard came on. I figured the problem was a bad alternator and ending up replacing it with a remanufactured carquest one. Everything was working great for about a month. Today as I'm driving the...
  8. SRX 2nd Generation Forum - 2010-2016
    Folks, We had a couple of issues happen simultaneously which I have since repaired but wanted to share this with the group and hope it helps someone with a similar situation(s). I have a 2011 SRX Performance with just over 200K miles. The warranty has long since expired so all repair work I...
  9. STS Forum - 2005-2012
    I replaced my alternator in my 2006 STS about a week ago. Since then I have been getting a high voltage warning on my dashboard, around 18+. All my accessories power off during this time. Finally about 7-10 min later voltage goes back to normal around 13V, and all my accessories turn back on. I...
  10. CTS First Generation Forum - 2003-2007
    My theft deterrent light wont turn off, my temperature and fuel gauges are dead, my traction control light is also on along with my ABS light. Also, nothing on my console really works either, I cant reset my trip meters or my trans and oil life percent. I'am a first time Cadillac owner and new...
  11. 2004-2007 CTS-V General Discussion
    good morning fella's...can someone tell me what kind is in our car..:hmm:.i need a bigger one and no one know's exactly what it is...i need to know make and amps...i need it for the stereo...lights are dimming...anyways, thanks for your info...scott..
1-11 of 11 Results
Top