Cadillac Owners Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 24 Results
  1. CTS First Generation Forum - 2003-2007
    So I just recently got a new 2005 Cadillac CTS with the 3.6 LY7 engine, i want something newer and nicer but I was in a huge rush to get a new car after my old one died so I could continue working lol, and I was wondering if there’s any possibility of putting a super charger on it (or a turbo...
  2. CTS First Generation Forum - 2003-2007
    Hi, does anyone have the flywheel attaching bolt torque specs for the 3.6L? I was not able to download the AY6 manual transmission docs from the FAQ section where this info is listed. Could really use the AY-6 trans manual if anyone has it.
  3. ATS General Discussion Forum
    The other day I lost my CUE display and Steering wheel lit buttons? I can get the air to run at least. I have the premium extended warranty. Anyone ever experience this? Thanks, Monti
  4. ATS General Discussion Forum
    Could anyone refer me to any sites with good prices on tires and rims for the 2013 ATS Premium 3.6L 275/30Z R19 245/35Z R19 93W Thanks
  5. CTS First Generation Forum - 2003-2007
    Hello, this is a guide on how I replaced the ECM on my '05 CTS. In total it only took me 30 mins. If you haven't bought one yet stay away from Flagship One and All Computer Resources. Step 1: Make sure you disconnect the negative battery cable before starting, the bolt size is 8mm/5/16" Step...
  6. CTS First Generation Forum - 2003-2007
    Hey everyone I have a major problem going on with my 2004 cts 3.6l base model I took on the job of working on the rear differential and drive shaft everything has went smooth until I decided to replace the shafts u joint thats located rear of the the center support bearing all good until I can't...
  7. CTS First Generation Forum - 2003-2007
    Replaced the spark plugs, cleaned the Throttle Body, and checked the Air filter. It vibrates at idle and worse when the Ac is on. When driving it’s bad at 30-50mph and smooths out after that. Motor and Trans mounts are solid. Curious if there’s something I’ve failed to check. Any and all info on...
  8. CTS First Generation Forum - 2003-2007
    Backstory For a while she was having a rough start and would sometimes die unless I gave her some gas. Then one day after a lot of driving and some idling that almost felt like I lost a ton of power and it would pulse on acceleration. Turns out oil was low and I had it changed and it seemed...
  9. 2008-2013 CTS General Discussion
    I am in love with my 2012 CTS coupe, not the V tho :/ but one day! 3.6L just over 100K the studdering at first would only happen under load like going uphill (bridge or on-ramp) but now it happens even when turning into a street or anything. Attached is a video showing how there is an interval...
  10. CTS First Generation Forum - 2003-2007
    i have a 2004 caddilac cts with the 3.6L engine, i picked it up for a good price down south in texas and drove it up to mid wisconsin during the winter and it sat in my driveway for one night and the next day when i went to drive it, it overheated for a little while then the temp leveled to...
  11. 2008-2013 CTS General Discussion
    Hey guys, So I recently bought a second hand 2009 CTS4 and have really been enjoying it. One thing I wanted to ask tho, I see this car should be averaging about 11-12 litres per 100km but right now I’m sitting at 17.3 per 100km. Is this normal or should I be worried there is something wrong? Car...
  12. ATS General Discussion Forum
    So I have a 2016 ATS 3.6 v6 which I bought used at 20k miles now up to 36k I love the car drives great but occasionally the check engine light comes on. I’ve taken to the local parts store to see what it reads and it says something about transmission temperature. The car drives like brand new...
  13. SRX 1st Generation Forum - 2004-2009
    Under the hood, once the engine idles down low, there's a persistent "ticking" from what would appear t be my fuel injector. Has anyone else had this issue? I've heard that it's a fairly common issue. I've tried Techron, which seems to have helped it some, but I'm wondering if I should get new...
  14. STS Forum - 2005-2012
    Hello, A friend of mine has an 07 sts. 3.6 LY7 and around 60k. Recently I replaced timing chains on his car as he drove about 450 mi on a set that was making some “real bad noises” and dealer verified this problem. I also ran codes before they diagnosed and came up with typical timing chain...
  15. C2C2409E-E2BF-4EF6-A90E-798B0828D4C9.jpeg

    Just an adventure through Colorado, Oklahoma, Texas, New Mexico.
  16. 512E60FA-C78E-47C0-BEC8-790048138BCA.jpeg

    Just an adventure through Colorado, Oklahoma, Texas, New Mexico.
  17. 3B422D0E-48F1-4866-8430-7BCB5CE1F76D.jpeg

    Just an adventure through Colorado, Oklahoma, Texas, New Mexico.
  18. D7F0D910-715F-41A1-8428-8FB159173024.jpeg

    Just an adventure through Colorado, Oklahoma, Texas, New Mexico.
  19. A11D253C-3BC0-4E6F-B218-C995A09185A2.jpeg

    Just an adventure through Colorado, Oklahoma, Texas, New Mexico.
  20. F869F23D-33DC-4473-845D-38C6104C1448.jpeg

    Just an adventure through Colorado, Oklahoma, Texas, New Mexico.
1-20 of 24 Results
Top