Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JULY's Ride of the Month Challenge!
2005 sts
1-6 of 6 Results
  1. STS Forum - 2005-2012
    I recently bought a 2005 Cadillac STS 4.6L AWD. I had a few issues I had to fix when I first bought it, but that was ok since I got a great deal on it. The issue I am having now is that when I am moving slow on a downhill grade and turn sharp to the left and brake or accelerate, the car goes...
  2. STS Forum - 2005-2012
    In June, my STS broke down at my cottage and was towed to an American car specialist (I live in Finland, no Cadillac dealers anymore) Finally, I got the car back. It was the stupid electric steering column lock, which I found lying around at my dealership. Now, though, the map is completely...
  3. STS Forum - 2005-2012
    Hey everyone. First Post here. I have an 05 STS with the dreaded E55 ECM. Long story short I built a bench harness for it following the ECM pins for GM LAN Bus +/-, IGN Volt (all 3 of them) switched, Battery+ (12V) and Ground (Screw on the ecm enclsoure). I’m using a 12V 1A power supply and...
  4. STS Forum - 2005-2012
    The white whale I have been chasing for a few years. My LH2 (~65k miles) has high LTFT (over 20%) on both banks during high engine vacuum, though bank 2 is higher and thus occasionally (maybe every four months) sets a P0174 after extended driving. At cruise or acceleration, LTFT are above 0% and...
  5. STS Forum - 2005-2012
    So my 2005 sts seems to be acting a little loopy on the electrical side... issues are as followed 1. Passenger door won’t open when unlocked I have to manually open it from inside.. 2. When I’m driving at night my high beams switch on and off sporadically on there own 3. Navigation screen...
  6. Black Raven

    2005 1SC Black Raven
1-6 of 6 Results
Top