Cadillac Owners Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-9 of 9 Results
  1. Audio, Video and Security Systems
    I have 2 12s subs in my trunk and aftermarket radio but my front sub blew when I didn't have the 12s so did my back sub but the audio shop disconnected the wiring from it. But my front sub I'm not positive if I can just disconnect the connectors or if I have to rewire the sub. I have 2002...
  2. Seville and Eldorado Forum
    Hi, I'm new to the forum. I'm working on my 2002 Eldorado, on both front seats the seat back latches do not lock the seats down wo they flop forward all the time. I've read about replacing the mechanism. I have unzipped the leather at the bottom the seat. But then I can't figure out how to get...
  3. FWD DeVille 1985-2005, Fleetwood, and 60 Special
    I posted a month ago or so about my car and possibly gasket issues but found out A LOT lately since inspecting it. Figured out something today. After fixing the leaking water pump and all that lately, And all this time figuring out why it was smoking despite passing the coolant tests and...
  4. FWD DeVille 1985-2005, Fleetwood, and 60 Special
  5. Escalade, EXT and ESV Forum - 1999-2006
    2002 Cadillac Escalade 6.0L V8. So my exhaust always smells like fuel and then I was trying to test something so I unplugged the MAF sensor then wen to start it and it doesn’t run without the MAF sensor being plugged in. If I unplug the MAF sensor while it’s running it will bark run. Also...
  6. Escalade, EXT and ESV Forum - 1999-2006
    So i was changing the camshaft sensor but i accidentally undid the wrong bolt. This bolt contained antifreeze or oil?....not sure. Its behind the engine to the right. I MUST KNOW does it originally have some rubber grommet/O ring or not? The thing wont seal and its on there tight as...
  7. FWD DeVille 1985-2005, Fleetwood, and 60 Special
    Blew the rear sub on this 2002 Cadillac deville I have so I put in an LOC and amp n subs. Well everytime I start the car I have to go back and unplug/plug back in the factory connector. Well I read on here that you need a resistor to keep it from doing this crap. Well I put the sub in the...
1-9 of 9 Results
Top