Cadillac Owners Forum banner

Reaction score
30

Profile posts Latest activity Discussions About

  • tomm ·
    I am long time Cadillac fan and I love the new Cadillac vehicles and I like to drive them hard. We also run Best Radar Detectors which is a popular radar detector website which specializes in high performance radar detectors. If you are looking for an Escort, Beltronics or any other detector give us a shout and we will see what we can do for you.
    mprice1975 ·
    Tom, got a quick question. I bought a lockpick kit for my 2006 STS V6 but have since upgraded to the 2007 STS-V and I was wondering if the lockpick kit I bought will still work. I believe the difference was that the 2007 and up models didn't need the auxilary button if they had a mute button on the steering wheel. Mine does so can it still be used or do I need to modify it?

    Thanks in advance,
    Mike
    Rockwall, TX
    mprice1975 ·
    Tom, I pulled things back apart and was able to get the audio fixed. Apparently a loose connection. The one problem that stll remains then is the GPS which wont reset when in place. Shows a Red Slash through GPS and it doesn't work whether confiured manually or not. I left it for a few days but nothing. I went ahead yesterday and pulled it all back out and the gps works again. I'm guessing that means its an antenna problem but not sure. I was not able to get it to work by bypassing your antenna and keeping the factory antenna hooked up but maybe I was just not patient enough. Anyhow... whats the next step. I guess i should send this back for exchange. Read more at http://www.cadillacforums.com/forums/member.php?u=21681&ktrack=kcplinkRead more at http://www.cadillacforums.com/forums/member.php?u=21681&ktrack=kcplink
    mprice1975 ·
    Tom, just to add to the information below I have also found that my sound system is off. It seams the speakers on the passenger side of the vehicle are either not working or very muffeled as though there's no amplification. I plan to go ahead later this week and totally remove the lockpick and test everything if it goes back to normal I'll just wait for your reply before movign forward.

    Thanks in advance,
    Mike
    mprice1975 ·
    Tomm, I have a question. i recently recieved the 2006 Lockpick Kit. It appears everything works great with the Video but I had noticed upon turing the car back on that the Time/Date Setting went blank. It has yet to come back on and wont allow me to reset it manually. Everything is grayed out. Also, the GPS is showing a slash through it. This was mentioned in the forum and apparently just requires recalibration however I have tried to recalibrate mine several times but it still acts like there is no GPS signal. I can pop the dash apart to try and get back to the antenna connectors again and verify that everything is hooked up still and didn't come loose upon sliding the stereo back in however getting those wires out of the way was a pain. Can you make any suggestions before I take that route?

    Mike
    bnagel ·
    Where exactly are the instructions. I have searched for sts lockpick but cannot find anything too helpful.
    Ben
    mxdxm ·
    Where can I go to buy the 2007 STS lockpick? Do you know if you can use the factory built in aux video in port while in motion with the lockpick? I want to add a Alpine Hub but needs a video input so I figured I could use the aux one in the center console. Thanks for your help!
    Sowdawg10 ·
    hello, new to the forum. I recently purchased the Lockpick 5 and installed using the direction found on the Coastetech website. When i turn the lockpick on and drive the dvd in motion works great. However, when i slow down the screen up front goes to a black screen and say "Service rear camera system" Any ideas on why this might be happening or how i could fix it? Thanks a lot.
    ski_loose ·
    Tomm,

    I purchased a lockpick for a 2006 sts. It doesn't appear to be working. I am not sure if I am doing something wrong. Is there anyway I can talk to you to ask a few questions? I am hoping that with a little trouble shooting we can get it working. Thanks. Troy
  • Loading…
  • Loading…
  • Loading…
Top