Very Strange Electrical Issues 93 STS
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

+ Reply to Thread
Results 1 to 2 of 2
Cadillac Seville / Cadillac Eldorado Forum Discussion, Very Strange Electrical Issues 93 STS in Past Cadillac Vehicle Discussion; Hi, I have a 93 Cadillac Seville STS that is having some strange electrical issues and am looking for some ...
  1. #1
    ATLSean74 is offline Cadillac Owners Member
    Join Date
    Apr 2005
    Posts
    7

    Question Very Strange Electrical Issues 93 STS

    Hi, I have a 93 Cadillac Seville STS that is having some strange electrical issues and am looking for some help, please! At night, my interior dash lights will not work unless my foot is on the brake pedal, and even then they are very dim. Also, when I turn the left turn signal on, the dash lights blink at the same rate as the turn signal. I have also noticed that all of the left side body lights are out...taillight, front marker light etc. I pulled the "left parking light" fuse in the trunk and it was blown so I replaced it. Then everything worked ok. I turned on the turn signal once more to check it and ALL the lights except the headlights started blinking. I turned the car on and the fuse blew once more, so now I am back where I started from, no left lights and having to push on the barke pedal to get any interior lights at all. Please help!! THanks!

  2. Remove Advertisements
    Cadillac Forums
    Advertisements
     

  3. #2
    ATLSean74 is offline Cadillac Owners Member
    Join Date
    Apr 2005
    Posts
    7
    Thread Starter

    Re: Very Strange Electrical Issues 93 STS

    Ok, problem solved. The left inner tail light was the cause. The contact points on the bottom of the bulb "fused" with the contact points on the bulb housing causing the short circuit. This happened to the right side as well a while back caused by condensation from a crack in the tail light housing. I suppose the contacts eventually rust from the moisture, which eventually leads to a short. It has actually gotten so bad that the light bulb cannot even be removed from the fitting (Rust+Moisture=Short Circuit) I unplugged the power source to the light and replaced the blown "left parking lamp" fuse and now everything is back to normal (almost). The light does not work now but I am going to buy the entire light housing (with new wires) off of ebay. This should certainly solve the problem for good. Will let you know what happens.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

What Cadillac(s) do you own? (Or type NONE)

Please select your insurance company (Optional)

Log-in


Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Genesis | Kia Forte Forum