Front Seat Heat/Cool not working - Need Help
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

+ Reply to Thread
Page 1 of 4 1234 LastLast
Results 1 to 15 of 60
Like Tree8Likes
Cadillac Escalade, EXT and ESV Forum - 2007-2014 Discussion, Front Seat Heat/Cool not working - Need Help in Cadillac Escalade Forums; All, 2007 Escalade ESV, out of warranty with 59k Both driver and passenger seats abruptly stopped heating or cooling. My ...
  1. #1
    Silverbuell is offline Cadillac Owners Member
    Automobile(s): 07 ESV
    Join Date
    Oct 2005
    Posts
    45

    Front Seat Heat/Cool not working - Need Help

    All,

    2007 Escalade ESV, out of warranty with 59k

    Both driver and passenger seats abruptly stopped heating or cooling. My daughter mentioned my wife and she smelled something burning about the same time. they noticed it.

    I've located the MSM (memory seat module) under the passenger seat. I removed it and inspected the circuit board and the connectors. All looks good!

    The service manual references Heated Seats 30amp fuse in the wiring diagram, but does not list a block# for it, and I cannot find it.

    Any suggestions?

    Tim in Fairfax, VA

  2. Remove Advertisements
    Cadillac Forums
    Advertisements
     

  3. #2
    cadmanchris's Avatar
    cadmanchris is offline Cadillac Owners Enthusiast
    Automobile(s): 2001 DTS,2007 STS V8
    Join Date
    Dec 2006
    Location
    New Jersey
    Age
    47
    Posts
    602

    Re: Front Seat Heat/Cool not working - Need Help

    Did you check the connectors fpr the climate control seat module? It's the bigger connector. Inspect the ground wire For a burned terminal. The module is under the passenger seat.

  4. #3
    Silverbuell is offline Cadillac Owners Member
    Automobile(s): 07 ESV
    Join Date
    Oct 2005
    Posts
    45
    Thread Starter

    Re: Front Seat Heat/Cool not working - Need Help

    I rechecked the the large connectors wiring for burnt wire or conenctors, and everythring is good. Also tested with car running connector to ground, and +12volts power. Both correct.

    Any more idea's?

  5. #4
    Silverbuell is offline Cadillac Owners Member
    Automobile(s): 07 ESV
    Join Date
    Oct 2005
    Posts
    45
    Thread Starter

    Re: Front Seat Heat/Cool not working - Need Help

    Quick Update thanks to warmer weather

    I removed the passenger seat and discovered the fans are working. I also located a Motorola control unit bolted ot the underside of the seat. When I pulled the power connectors, I discovered a semi-melted ground connector. The circuit board appears ok, with no discoloration or evidence of burnt components, so I am going to clean the ground connectors and reattached, hoping it will work. If so, then I will repeat the same on the drivers side.

  6. #5
    cadmanchris's Avatar
    cadmanchris is offline Cadillac Owners Enthusiast
    Automobile(s): 2001 DTS,2007 STS V8
    Join Date
    Dec 2006
    Location
    New Jersey
    Age
    47
    Posts
    602

    Re: Front Seat Heat/Cool not working - Need Help

    That module is the climate control seat module. There is only one under the passenger seat. There is not one under the driver's seat. Repairing the ground terminal should fix both seat heaters/coolers.

  7. #6
    Silverbuell is offline Cadillac Owners Member
    Automobile(s): 07 ESV
    Join Date
    Oct 2005
    Posts
    45
    Thread Starter

    Re: Front Seat Heat/Cool not working - Need Help

    Cadmanchris,

    Thanks for saving me from removing the drivers seat. Even with the service manual and various on-line parts catalougs identifying the various modules under the seats is challanging.

    One thing a bit odd, It was a 12v plus power wire, not a black ground that had burnt/melted, not the black ground.

    Going out to test the drivers seat heat now!

    Tim in Fairfax, VA

  8. #7
    Silverbuell is offline Cadillac Owners Member
    Automobile(s): 07 ESV
    Join Date
    Oct 2005
    Posts
    45
    Thread Starter

    Re: Front Seat Heat/Cool not working - Need Help

    My seat heater problems continue....

    Does anyone have a solution as to how I can repair or replace the connector block that connects to the climate control module under the passenger seat of my 2007 ESV?

    The +12V side at the wiring harness connector which plugs into the climate control module under the passenger seat has partially melted, preventing the connectors from maintaining a secure connection.The connector plastic around the 12V wire and balde connector has turned black and is brittle. From what I can see, it really looks like a manufacturing design flaw which allows the connector to overheat in this area. I do not see any way to bypass the power around the connector.

    I'm open to suggestions, as my ESV is at 59k and out of warranty.

    Thanks

    Tim in Fairfax

  9. #8
    darhef is offline Cadillac Owners Fanatic
    Automobile(s): '07 Escalade
    Join Date
    Oct 2010
    Posts
    116

    Re: Front Seat Heat/Cool not working - Need Help

    I had the same thing happen to me. Although it was only the ground (black wire) connector that was burnt. I pulled off the module opened it up, checked the circuit board for damage, cleaned the terminals and tightened the connector with a pic, put it back together and works fine...thanks to cadmanchris. Unfortunately yours maybe burnt beyond repair.

  10. #9
    cadmanchris's Avatar
    cadmanchris is offline Cadillac Owners Enthusiast
    Automobile(s): 2001 DTS,2007 STS V8
    Join Date
    Dec 2006
    Location
    New Jersey
    Age
    47
    Posts
    602

    Re: Front Seat Heat/Cool not working - Need Help

    I did the same to mine, but you may need a replacement terminal or maybe the pigtail itself. My connector was melted but I managed to clean it up and it still works fine.

  11. #10
    Big Windy Ext's Avatar
    Big Windy Ext is offline Cadillac Owners Enthusiast
    Automobile(s): Caddy EXT
    Join Date
    Aug 2009
    Location
    Downers Grove Il
    Posts
    633

    Re: Front Seat Heat/Cool not working - Need Help

    I believe you can go to the GM parts counter and they can identify what terminals and plug housing you have . The dealer I went to did this for my heated/cooled cupholder project . He didn't have the plug , but had the terminals , he also allowed me to find the plug I needed on a warranty harness they were returning to GM. Good Luck !! My gal would be lost without that butt warmer !!

  12. #11
    Silverbuell is offline Cadillac Owners Member
    Automobile(s): 07 ESV
    Join Date
    Oct 2005
    Posts
    45
    Thread Starter

    Re: Front Seat Heat/Cool not working - Need Help

    Big Windy Ext,

    Great suggestion! I"ll swing by the dealer and give it a go.

    Regards,

    Tim in Farifax

  13. #12
    cadmanchris's Avatar
    cadmanchris is offline Cadillac Owners Enthusiast
    Automobile(s): 2001 DTS,2007 STS V8
    Join Date
    Dec 2006
    Location
    New Jersey
    Age
    47
    Posts
    602

    Re: Front Seat Heat/Cool not working - Need Help

    Terminal #15304711
    Tray #8
    Tray Cavity #11


    Give this to your GM dealer.This is the terminal part #.

  14. #13
    Silverbuell is offline Cadillac Owners Member
    Automobile(s): 07 ESV
    Join Date
    Oct 2005
    Posts
    45
    Thread Starter

    Re: Front Seat Heat/Cool not working - Need Help

    has anyone had Cadillac acknowledge the problem with the overheating wires and connectors for out of warranty Escalades?

    My dealer has told me they have to inspect it, and then I can call Cadillac to register a complaint. I do not want to have to pay the dealer to simply document the problem.

    Has anyone had it fixed out of warranty by cadillac for free?

    Thanks
    07 ESV 59k and out of warranty
    Tim in Fairfax, VA

  15. #14
    Mha
    Mha is offline Cadillac Owners Fanatic
    Automobile(s): none
    Join Date
    Dec 2010
    Posts
    234

    Re: Front Seat Heat/Cool not working - Need Help

    How long should it take to cool and heat seats? Mine cools but takes forever. Andi just tried to heat my seats but it seamed to turn off as soon as I turned it on(the screen sign stays on but the sounds of it powering up turn off)could this have something to do with the outside temp(its kind of warm right now). Im also unable to get my heated steering wheel to turn on, no light or anything.

    Im still under warranty so I was going to take it in to get an outside handle fixed and get every thing checked out but didnt want to sound dumn if thats normal not to turn on warm days

    Thanks

  16. #15
    Playdrv4me's Avatar
    Playdrv4me is offline Cadillac Owners 10000+ Posts
    Automobile(s): 1992 STS / 2005 MB G500 / 2003 STS / 2006 XLR-V
    Join Date
    Nov 2003
    Location
    TPA / STL / ICT / SAT
    Posts
    11,694

    Re: Front Seat Heat/Cool not working - Need Help

    Is this module accessible with the seat still in the truck by chance? My heated and cooled seats are inoperative but my primary junction connector on the floor is just fine. Which means it must be the connection at the module that has burnt up. You would think GM would have done this right to begin with or address it with a recall as overheating parts are never good for safety. Appreciate the help.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

What Cadillac(s) do you own? (Or type NONE)

Please select your insurance company (Optional)

Log-in


Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Genesis | Kia Forte Forum