Bad TPMS Sensor?
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

+ Reply to Thread
Results 1 to 6 of 6
Cadillac Escalade, EXT and ESV Forum - 2007-2014 Discussion, Bad TPMS Sensor? in Cadillac Escalade Forums; 2008 Escalade ESV. On the dash, I noticed my passenger front tire pressure was going crazy over the weekend. From ...
  1. #1
    rmurray is offline Cadillac Owners Member
    Join Date
    Dec 2017
    Posts
    32

    Bad TPMS Sensor?

    2008 Escalade ESV. On the dash, I noticed my passenger front tire pressure was going crazy over the weekend. From 1 PSI to 70 PSI. The numbers were jumping all over the place. Now, it seems to be holding at 7 PSI, even though all the tires are at 35. I am getting a tire pressure warning light as a result. Is there something I can do to troubleshoot this particular sensor? Is there wiring that could be bad, or is this the sign of a worn out sensor? I'm not the original owner, so I don't know how old the sensors are. I tried going through the relearning process, but when I get to the passenger front, it does not seem to register. Any insight is appreciated. Thanks!

  2. Remove Advertisements
    Cadillac Forums
    Advertisements
     

  3. #2
    johninsc is offline Cadillac Owners Member
    Join Date
    Jan 2016
    Location
    West Columbia, SC
    Age
    44
    Posts
    23

    Re: Bad TPMS Sensor?

    Mine went from reading pressure to showing " -- ". That's all I got for you.

  4. #3
    rmurray is offline Cadillac Owners Member
    Join Date
    Dec 2017
    Posts
    32
    Thread Starter

    Re: Bad TPMS Sensor?

    Quote Originally Posted by johninsc View Post
    Mine went from reading pressure to showing " -- ". That's all I got for you.
    Did you have to replace it? Did you replace just one?

  5. #4
    johninsc is offline Cadillac Owners Member
    Join Date
    Jan 2016
    Location
    West Columbia, SC
    Age
    44
    Posts
    23

    Re: Bad TPMS Sensor?

    I replaced them all. They started one by one doing that over a month or two.

  6. #5
    rmurray is offline Cadillac Owners Member
    Join Date
    Dec 2017
    Posts
    32
    Thread Starter

    Re: Bad TPMS Sensor?

    Ok, so it sounds like they are going bad. I wasn't sure if that was the typical behavior of a sensor that is going bad, or if it was something else. Thanks!!

  7. #6
    sp00fy is offline Cadillac Owners Member
    Automobile(s): 2010 Hybrid Escalade
    Join Date
    Mar 2019
    Posts
    10

    Re: Bad TPMS Sensor?

    This started happening to me 2 days ago.. All tires are fine, but now receiving this warning in my 2010 Hybrid Escalade
    Untitled.png
    Can a general mechanic fix this, or does it need to be taken to Cadillac?

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

What Cadillac(s) do you own? (Or type NONE)

Please select your insurance company (Optional)

Log-in


Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Genesis | Kia Forte Forum