heater Blower motor not running
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

+ Reply to Thread
Results 1 to 6 of 6
Cadillac Allante Forum Discussion, heater Blower motor not running in Past Cadillac Vehicle Discussion; I bought a new resistor and installed it and the fam for the HVAC will not do anything. $135 for ...
  1. #1
    canukdon@outlook.com is offline Cadillac Owners Member
    Automobile(s): 1989 Allante
    Join Date
    Jul 2018
    Location
    Columbia,MO.
    Posts
    13

    heater Blower motor not running

    I bought a new resistor and installed it and the fam for the HVAC will not do anything. $135 for nothing.
    I have +power at the small plug on the resistor and a ground, I have jumped across the 4 pin connector to bypass the relay and the fam ran on maximum, it is good.

    I tried the defrost and heat, vent settings while I had it shorted and it cycled between them with the car running and the AC cold.
    The in dash control display seems to be working fine.
    Any suggestions where the problem is?

  2. Remove Advertisements
    Cadillac Forums
    Advertisements
     

  3. #2
    canukdon@outlook.com is offline Cadillac Owners Member
    Automobile(s): 1989 Allante
    Join Date
    Jul 2018
    Location
    Columbia,MO.
    Posts
    13
    Thread Starter

    Re: heater Blower motor not running

    Update, following the instructions for testing in the shop manual, it seems to point to a faulty HVAC controller behind the glove compartment. I will have to find one and try it. From testing it with my meter on the plug end, I now have a "system fault" on the console diagnostics that will not clear, it was working perfect before this??

  4. #3
    canukdon@outlook.com is offline Cadillac Owners Member
    Automobile(s): 1989 Allante
    Join Date
    Jul 2018
    Location
    Columbia,MO.
    Posts
    13
    Thread Starter

    Re: heater Blower motor not running

    After testing with a meter for power, the fault seems to be the HVAC controller behind the glove compartment. Unfortunately I have caused another issue , the console diagnostics now shows a system fault that does not allow it to do anything. I disconnected the battery, system fault is still there.
    I will buy a controller and see if the heater fan starts working.

  5. #4
    gdaquilina is offline Cadillac Owners Fanatic
    Automobile(s): 1994 Concours DeVille, (2) 1993 Allante
    Join Date
    Sep 2013
    Location
    Amherst NY
    Posts
    272

    Re: heater Blower motor not running

    Try disconnecting the battery again but this time touch the + and - leads to each other to discharge any residual power from many of the modules. Then reconnect the battery and see if you still have the System fault.

    You may have accidentally back probed the HVAC controller male plug end which could very well cause the system fault. If your DIC is still locked up with the code, go through your Service Manual for System Fault diagnosis suggestions. Suggest that you start with the BCM diagnosis section. Similarly if you accidentally back probed the female end of the Controller if may be fryed and when you reconnected it would register a System Fault as a disabled module. (Bad or dying modules often trip the System Fault message.

    Hopefully you can get the DIC unlocked- it's very difficult to continue the diagnostics without it. Even if you had an OBD I reader, if the DIC is locked you may not be able to enter diagnostics.

  6. #5
    canukdon@outlook.com is offline Cadillac Owners Member
    Automobile(s): 1989 Allante
    Join Date
    Jul 2018
    Location
    Columbia,MO.
    Posts
    13
    Thread Starter

    Re: heater Blower motor not running

    Got the system fault cleared. Back to the blower fan not working. I have changed the controller behind the glove compartment and the fan speed controller in the fan box under the hood, still no blower motor, not even low. Any suggestions? Seems like it may be the in dash unit but all level and temp controls work correctly ??

  7. #6
    Ross_blk_93_Pa is offline Cadillac Owners Fanatic
    Automobile(s): 1993 allante 91 allante
    Join Date
    Feb 2015
    Location
    north east Pa
    Age
    62
    Posts
    103

    Re: heater Blower motor not running

    Ok I spent Hours solving this problem did exactly what you did changed the module the hvac controller even went so far as to change the a/c module very frustrated i pulled all the fuses from the fuse panel under the ash trey and found 1 of the connections to the fuse itself had pushed itself so far down into the fuse panel as to not make contact with the fuse. i removed the center console glove box and was able to reinsert the wire back into the fuse box.

    Ross

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

What Cadillac(s) do you own? (Or type NONE)

Please select your insurance company (Optional)

Log-in


Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Genesis | Kia Forte Forum