2003 CTS 80000 miles runs rough only at idle
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 8 of 8
V6: 3.0, 3.2 LA3, 3.6 LY7, 3.6 DI LLT Discussion, 2003 CTS 80000 miles runs rough only at idle in Cadillac Engine Technical Discussion; I have a 2003 cadillac cts that misfires 1, 3, 5 cyl when at idle. Codes are p0300 p0301 p0303 ...
  1. #1
    caleb is offline Cadillac Owners Member
    Automobile(s): cts
    Join Date
    Sep 2013
    Age
    49
    Posts
    4
    I have a 2003 cadillac cts that misfires 1, 3, 5 cyl when at idle. Codes are p0300 p0301 p0303 p0305. These are my only codes, so far changed plugs, swap coils, inspected v/c gaskets and spark plug wells no oil leakage. Check wiring, vacuum lines associated with 1 3 5 bank no problems or leaks. Compression good no antifree leaks. Went and got gm fuel inj cleaner from dealer no change. I use 91 octane only. Car has great power, speed, and acceleration. No trouble starting, starts up everytime no problem. Note: idle good first thing in morning when its first started until car warms up then it runs rough. Rpms go from 800 smooth rpms to 600 rough rpms in the am. Stays at 600 after warming up with a rough idle.
    Any suggestions running out of ideas, but I bet its something right under my nose I'm missing. Timing belt done at 60000. Problem started right after getting gas 1 1/2 weeks ago.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    lukes03cts is offline Cadillac Owners Member
    Automobile(s): CTS
    Join Date
    Oct 2013
    Posts
    2

    Re: 2003 CTS 80000 miles runs rough only at idle

    Caleb, If i could describe what was happening to my car it would be almost exactly what is happening to yours. One thing to add is that I went to the dealer to
    get the idle raised which was suggested on this forum. It didn't help. As soon as I started driving the damn check engine light came on again for misfires on 1 3 and 5 . So I brought the car back to the dealer and they determined the intake manifold gasket was installed incorrectly when I did the timing chain. They checked the timing marks which were correct. And they said I had the wrong plugs in there so that could be a culprit. I had them put the proper plugs in and also fix the gasket. But to disappointment this problem still persists. I am at my wits end. Next is the coil pack switcharoo . I understand that these engines idle like shit and there is no fix for that. I even took the pedal apart and put a shim in the pedal with a lego from my kids . That worked for a day then the pedal went crazy and now doesn't work. I ordered a new pedal . This is by far the worst car I have ever owned. I cannot believe how many electrical and mechanical problems I have had with this cts.

    ----------

    I dont care if it idles like shit but having a check engine light come on all the time is absolutely unacceptable to me.

  4. #3
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    22,716
    When was the TB last cleaned?

  5. #4
    lukes03cts is offline Cadillac Owners Member
    Automobile(s): CTS
    Join Date
    Oct 2013
    Posts
    2

    Re: 2003 CTS 80000 miles runs rough only at idle

    Just did a throttle body cleaning . Still running like crap . I reset the ECM codes tried again & still flashing CEL with misfire on 1 , 3 & 5 .

  6. #5
    SC2150's Avatar
    SC2150 is offline Cadillac Owners Connoisseur
    Automobile(s): CTS
    Join Date
    Feb 2012
    Location
    Palmetto, FL
    Age
    58
    Posts
    1,734

    Re: 2003 CTS 80000 miles runs rough only at idle

    Plugs? LY7 is a hard engine to do plugs on, have to remove the intake manifold and lukes has posted some good info as well.
    RX Performance Products/RevXtreme.com 941-721-1826

  7. #6
    Edi
    Edi is offline Cadillac Owners Member
    Automobile(s): CTS 3.2 2003 Auto
    Join Date
    Dec 2011
    Age
    41
    Posts
    1

    Re: 2003 CTS 80000 miles runs rough only at idle

    caleb and lukes, I have been heavily chasing this damn problem in my 03 CTS since 1.5 years now , car has done 75K miles and started at 60K, I have done exactly what you guys have done and seen all what you described. then stopped . recently the RH side catalyst blasted out as a result so I went I changed all gaskets then replaced both catalysis with magnaflow free flow and CAT back ( I'm doing some tuning as well ) .I still get p0300 p0301 p0303 p0305. The car has gained more horse power but this is still irritating me so much!.

    I have scanner and proper tools, I went and followed some service manuals ; I can only suspect something common in between 3 of them 1,3 and 5. One mostly will start the misfire cycle and move to the next one as I have seen on the scanner .
    I cleaned fuel tank and fuel lines and changed fuel filter; had the injectors cleaned at service center and upper Throttle body plus Air intake caskets been changed and cam cover gaskets and bolts ring for the cover.

    I'm now convinced it has nothing with fuel air mixture and it has to be some damn electric issue ; I would say either a harness problem which is really so difficult to trace Or the ECM it self is not properly igniting at low rpms for that side.

    I'm now more determined to chase it to the end ; as I already spent a lot and tried few mechanics who just took money and did nothing! so I will do it my self. just ordered and new ecm and will have it programmed then will check and let you know how it goes. I might also check and change the lower Air intake gaskets ( Flange ) though its a pain in the ass .

    will post result once i reach into something.

  8. #7
    SC2150's Avatar
    SC2150 is offline Cadillac Owners Connoisseur
    Automobile(s): CTS
    Join Date
    Feb 2012
    Location
    Palmetto, FL
    Age
    58
    Posts
    1,734

    Re: 2003 CTS 80000 miles runs rough only at idle

    Injector issue then is where I am at...especially as you state the cat failed (sure sign of a stuck injector flooding fuel in that bank).

    At idle, try disconnecting one coil at a time to see if one does not cause the idle to drop and that is the cylinder to blame. Try replacing that injector then and I am willing to bet your problem goes away.
    RX Performance Products/RevXtreme.com 941-721-1826

  9. #8
    gavagni1 is offline Awaiting Email Confirmation
    Join Date
    Dec 2013
    Posts
    1

    Re: 2003 CTS 80000 miles runs rough only at idle

    have the same problem with my cadillac cts 2004 with 85000 miles i have error codes p0300,p0301,p0302,p0303

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting