backfiring on 3.0 catera
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 2 of 2
V6: 3.0, 3.2 LA3, 3.6 LY7, 3.6 DI LLT Discussion, backfiring on 3.0 catera in Cadillac Engine Technical Discussion; My 1997 Catera, 175,000 has been running great. On a 250 mile trip last weekend, it started getting rough and ...
  1. #1
    tony.menyhart is offline Cadillac Owners Member
    Automobile(s): Cadillac Catera 1997
    Join Date
    Oct 2008
    Location
    Ann Arbor, Michigan
    Age
    65
    Posts
    1

    backfiring on 3.0 catera

    My 1997 Catera, 175,000 has been running great. On a 250 mile trip last weekend, it started getting rough and noisy. So noisy I thought there must be a hole in the muffler. I took it to my local guy, not a Caddy dealer, he found nothing physical, and checked the computer.

    So I started driving today. When letting off the gas, the engine became noisy, and it felt like a backpressure roar. At very low speeds it actually backfired and stopped the car.

    Any ideas on what causes this?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    eastsidercaddy's Avatar
    eastsidercaddy is offline Cadillac Owners Fanatic
    Automobile(s): '97 Black Catera
    Join Date
    Jan 2008
    Location
    Jacksonville NC
    Age
    25
    Posts
    210

    Re: backfiring on 3.0 catera

    Do you have the timing belt history on this vehicle? I own a 97 catera and that's the ONLY thing i don't have history on. The engine was rebuilt around 51,000 miles and recently my oil cooler was shot. When they did the rebuild, they used the same oil cooler! I'm hoping they didn't use the same timing belt!

    That's the only thing that could come to mind, unless it's a head gasket problem. I would also like to ask if you have thought about using a fuel injector cleaner/octane booster. If possible please post a video of engine at idle and using the throttle to revv the engine. Lots of stuff i know but sounds like the problem could be found/fixed or something else may be going on.

    Hope that helps!!

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting