Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 5 of 5

Thread: Suspension Air pump Relay or Module Location

  1. #1
    Join Date
    Aug 2003
    Location
    Des Moines, Iowa
    Age
    76
    Posts
    17

    Suspension Air pump Relay or Module Location

    1994 Sts. Can anyone tell me where the Air ride pump Relay or module is located, probably in the trunk behind the seat???


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Join Date
    Jan 2003
    Location
    Newtown, PA
    Age
    58
    Posts
    6,472

    Re: Suspension Air pump Relay or Module Location

    Hell, I'm not sure. I could guess but that's not fair to you. I'll look it up in the a.m. and get back to you.

  4. #3
    Join Date
    Aug 2003
    Location
    Des Moines, Iowa
    Age
    76
    Posts
    17

    Re: Suspension Air pump Relay or Module Location

    Quote Originally Posted by Katshot
    Hell, I'm not sure. I could guess but that's not fair to you. I'll look it up in the a.m. and get back to you.
    Appreciate your help!

  5. #4
    Join Date
    Jan 2003
    Location
    Newtown, PA
    Age
    58
    Posts
    6,472

    Re: Suspension Air pump Relay or Module Location

    OK, The compressor and exhaust solenoid are under the car together. The ELC relay is in the trunk in the #2 relay panel. The system is powered by (2) fuses, one (a 10amp) in the engine compartment fuse block and one (a 20amp) in the trunk fuse block.

  6. #5
    Join Date
    Aug 2003
    Location
    Des Moines, Iowa
    Age
    76
    Posts
    17

    Re: Suspension Air pump Relay or Module Location

    Quote Originally Posted by Katshot
    OK, The compressor and exhaust solenoid are under the car together. The ELC relay is in the trunk in the #2 relay panel. The system is powered by (2) fuses, one (a 10amp) in the engine compartment fuse block and one (a 20amp) in the trunk fuse block.
    I put in a new relay & fuses are good. pump fires up ONLY when I jump 12 volts to it. info center reads Service Ride System & I cannot get the message out. I think it takes a scanner to remove message & then perhaps the system will activate. Any opinion would be appreciated.


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum