Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 2 of 2

Thread: Please Help! Eletronic Leving Help!!!!

  1. #1
    David Post is offline Cadillac Owners Member
    Automobile(s): 97 Deville
    Join Date
    Aug 2011
    Location
    Porterville, California, Unite
    Age
    28
    Posts
    3

    Please Help! Eletronic Leving Help!!!!

    hey im having the same problem with my 97 caddilac deville, i have checked the BODY 2 fuse witch my manual says controls the Eletronic Leveling System. i have also got under the car and checed connections and hoses all of witch look good...my commpresor just makes no noise and dosent turn on at all.... and also i dont know if this problem is related ( very possibly is) my digital spedomiter has quit working, check engine light seat belt etc. work but the spedomited itself no linger turns on... the tail of my car is riding realy low and im hoping to fix it before and permant damage is done.... help with either problem would be GREATLY appriciated...thank you very much.


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Submariner409's Avatar
    Submariner409 is offline If it won't run, chrome it
    Automobile(s): 2002.5 F55 STS - 67,500 miles, 2014 Explorer XLT FWD
    Join Date
    Feb 2006
    Location
    MD Eastern Shore, Kent Island
    Age
    77
    Posts
    56,842

    Re: Please Help! Eletronic Leving Help!!!!

    Didn't you just double post this up in Deville ???........


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum