Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 2 of 2

Thread: RearIntegrationModule RIM HELP!!

  1. #1
    Join Date
    Nov 2004
    Location
    Upstate, NY
    Posts
    40

    RearIntegrationModule RIM HELP!!

    So I realized that my rear air ride is not functioning on my 2000 DeVille.

    Stop over at my buddies garage and plug in the Tech 2 and cannot control the compressor. We checked the level sensor and it is working properly, and checked all of the fuses and relay's and they are all fine.

    I can start the compressor at the fuse block and at the RIM using a test light. I can exhaust the system at the pump.

    Everything seems in order, it just won't do it on it's own. Is it or could it be the rear integration module? This seems to be the missing link in the correct opperation of the entire system.

    Before I spend the coin, I was wondering if anyone has a sure fire way of testing this thing? And, have I made the correct diagnosis?

    Thanks in advance!

    Dave


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Join Date
    Nov 2004
    Location
    Upstate, NY
    Posts
    40

    Re: RearIntegrationModule RIM HELP!!

    Well, I purchased a used RIM and pluged it in...It didn't fix it.

    Anybody?

    Dave


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum