Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Page 2 of 2 FirstFirst 12
Results 16 to 22 of 22

Thread: Gas Tank Problems

  1. #16
    Join Date
    Apr 2003
    Location
    New Mexico
    Age
    55
    Posts
    25
    I'm sorry, I did order the sending unit. But now just this morning with 15 gallons showing, she cut out on me. Starting to think it's just the fuel pump. Of course, buying the sending unit and fuel pump should get me covered. If it happens after that, tank or electrical. I had a Cadillac guy tell me today that he suspected the fuel pump. Huh!!!!!!!!!


  2. #17
    Join Date
    Apr 2003
    Location
    New Mexico
    Age
    55
    Posts
    25
    Hey guys!

    Has there ever been any ride height issues associated with this fueling problem? Here's why I ask. Say you have 2 adults (300lbs) riding in the front of the car with no weight in the back, so that you initially change the ride height, and you're still having the cutting out problem. Then you head to the grocery store and add a 100lbs or so of them to the trunk. Our trip is 40 miles round trip. No cutting out whatsoever occurred on the trip home. Anyone checked this?

  3. #18
    kcnewell is offline Cadillac Owners Connoisseur
    Join Date
    Jan 2003
    Location
    Nevada, Still the land of the free!
    Posts
    2,235
    I take it that the "Level Ride" is non op. because if it works that would have NO effect whatsoever.

    Is that 300 pounds each or 300 pounds total? If it's the former...Them's a couple "O" big'uns. If it's the latter...Them's a couple "O" little'uns!
    Last edited by kcnewell; 05-17-03 at 05:47 PM.

  4. #19
    jadcock's Avatar
    jadcock is offline Cadillac Owners Connoisseur
    Automobile(s): White Diamond 2001 STS
    Join Date
    Jan 2003
    Location
    North Carolina
    Age
    38
    Posts
    1,317
    Or maybe one of both... I weigh more than double my wife, but together we're still just 330 pounds. :-)

  5. #20
    Join Date
    Apr 2003
    Location
    New Mexico
    Age
    55
    Posts
    25
    that's 300lbs total. i'm going to pick up a sand bag and run awhile with that. am replacing the fuel pump, as everyone has suggested to me, and the fuel filter. the sending unit should be ok sense the guages (digital) works fine. i ran the a/c and the stereo on the trip into town and it starting surging and cutting out 10 miles down the road with 15 gal showing. we made it to town, bought groceries and headed back. the car ran like a champ however, we didn't run the a/c or stereo. the stereo has the power antenna.

  6. #21
    Join Date
    Apr 2003
    Location
    New Mexico
    Age
    55
    Posts
    25
    Replaced the cam sensor and ignition module first. Sent the sending unit back and bought the right fuel pump. Problem solved. Running like a champ. Thanks for your thoughts guys.

  7. #22
    Elvis's Avatar
    Elvis is offline Cadillac Owners Master
    Automobile(s): '05 Expedition
    Join Date
    Jan 2003
    Age
    52
    Posts
    7,651
    We need to start a FAQ archive to permanently save threads like this. Even if it takes three months to get a definitive answer, it can be very helpful to someone in the future.

Page 2 of 2 FirstFirst 12

Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum