Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Page 3 of 5 FirstFirst 12345 LastLast
Results 31 to 45 of 74

Thread: Engine HOT - A/C off on 2006 STS-V

  1. #31
    rakoom2002 is offline Cadillac Owners Fanatic
    Automobile(s): STS-V
    Join Date
    Nov 2010
    Age
    32
    Posts
    178

    Re: Engine HOT - A/C off on 2006 STS-V

    Ugh, this stupid light keeps coming on. Replacing Thermo, and Water Pump since it's leaking. The damn dealer wanted around $1000 to fix both lol. Luckily one of their retired mechanics just lives up the street from me.


  2. #32
    KingOfLacs is offline Cadillac Owners Fanatic
    Automobile(s): 06 STS-V Allante, 2 Eldo's V8 STS CTS-V DTS CTS Fleetwood
    Join Date
    Dec 2011
    Age
    34
    Posts
    320

    Re: Engine HOT - A/C off on 2006 STS-V

    temp gauge is not working as of last night. After reading this post it looks like I have the same issue with bad t=stat (engine hot a/c off). Dublin Caddy ordered parts will have to wait till Friday their coming from reno. I was going to put the stock factory t-stat back in whadda think. Also going for a tune and exhaust any input would be helpful.

    Joe

  3. #33
    KingOfLacs is offline Cadillac Owners Fanatic
    Automobile(s): 06 STS-V Allante, 2 Eldo's V8 STS CTS-V DTS CTS Fleetwood
    Join Date
    Dec 2011
    Age
    34
    Posts
    320

    Re: Engine HOT - A/C off on 2006 STS-V

    Ok factory delco t-stat in no more hot engine shoot on my dash hell yes

  4. #34
    Chuck. is offline Cadillac Owners Member
    Automobile(s): 08 STS-V
    Join Date
    Oct 2011
    Age
    32
    Posts
    20

    Re: Engine HOT - A/C off on 2006 STS-V

    I had the same problem replaced t-stat and it has not come back its been a month.

  5. #35
    Bradkoen is offline Cadillac Owners Member
    Automobile(s): NONE
    Join Date
    Jan 2011
    Location
    Austin, Tx
    Age
    46
    Posts
    15

    Re: Engine HOT - A/C off on 2006 STS-V

    I have the same problem even after changing the Tsat. The water pump was replaced 2 months ago under warranty. Any other suggestions? I might go try unplugging the positive battery cable for 30 seconds, but I am not optimistic about this working.

  6. #36
    PGA2B's Avatar
    PGA2B is offline Cadillac Owners Connoisseur
    Automobile(s): 2013 OBM CTS-V Coupe
    Join Date
    Jun 2009
    Location
    USA
    Posts
    2,662

    Re: Engine HOT - A/C off on 2006 STS-V

    You might pull out the T-Stat and test it. There have been some bad right out of the box.

  7. #37
    Bradkoen is offline Cadillac Owners Member
    Automobile(s): NONE
    Join Date
    Jan 2011
    Location
    Austin, Tx
    Age
    46
    Posts
    15

    Re: Engine HOT - A/C off on 2006 STS-V

    Replaced the new Tstat with yet another Tstat and got the same results. Not to sure how to test them, cause I dropped them in hot boiling water and could see anything change. So, I decided I would try the removal of the positive battery terminal for 30 seconds and whahla, the temp. gauge started to working and the error message went away. Darn, what a way to spend my day off.

  8. #38
    PGA2B's Avatar
    PGA2B is offline Cadillac Owners Connoisseur
    Automobile(s): 2013 OBM CTS-V Coupe
    Join Date
    Jun 2009
    Location
    USA
    Posts
    2,662

    Re: Engine HOT - A/C off on 2006 STS-V

    When you put it on boiling water it should open. It should open somewhere near the rated temp.

  9. #39
    550HP STSV Guest

    Re: Engine HOT - A/C off on 2006 STS-V

    Jamie, pay your damn cell phone bill. I just called it and it said its disconnected. call me

  10. #40
    PGA2B's Avatar
    PGA2B is offline Cadillac Owners Connoisseur
    Automobile(s): 2013 OBM CTS-V Coupe
    Join Date
    Jun 2009
    Location
    USA
    Posts
    2,662

    Re: Engine HOT - A/C off on 2006 STS-V

    Quote Originally Posted by 550HP STSV View Post
    Jamie, pay your damn cell phone bill. I just called it and it said its disconnected. call me 866-236-5031
    It would help if you called the right number..........

  11. #41
    550HP STSV Guest

    Re: Engine HOT - A/C off on 2006 STS-V

    is 816-885-xxxx not your old number?

  12. #42
    PGA2B's Avatar
    PGA2B is offline Cadillac Owners Connoisseur
    Automobile(s): 2013 OBM CTS-V Coupe
    Join Date
    Jun 2009
    Location
    USA
    Posts
    2,662

    Re: Engine HOT - A/C off on 2006 STS-V

    Optimum word being "OLD"

    Now get back to the topic!

  13. #43
    KingOfLacs is offline Cadillac Owners Fanatic
    Automobile(s): 06 STS-V Allante, 2 Eldo's V8 STS CTS-V DTS CTS Fleetwood
    Join Date
    Dec 2011
    Age
    34
    Posts
    320

    Re: Engine HOT - A/C off on 2006 STS-V

    Did It again just replaced t-stat think it could be the actual temp sensor? Temp gauge not working light comes on engine hot / ac off oil temp is between 158-165.

  14. #44
    PGA2B's Avatar
    PGA2B is offline Cadillac Owners Connoisseur
    Automobile(s): 2013 OBM CTS-V Coupe
    Join Date
    Jun 2009
    Location
    USA
    Posts
    2,662

    Re: Engine HOT - A/C off on 2006 STS-V

    Are you throwing any codes? Could be the temp sensor but I don't know of any easy way to test it.

  15. #45
    KingOfLacs is offline Cadillac Owners Fanatic
    Automobile(s): 06 STS-V Allante, 2 Eldo's V8 STS CTS-V DTS CTS Fleetwood
    Join Date
    Dec 2011
    Age
    34
    Posts
    320
    Yup finally threw a code had to drive it for a while. Scanned it P0128 coolant temp below Thremostat regulating temp. Cleared it we shall see if it comes back on. I haven't driven it since then i will chime in if it does.

Page 3 of 5 FirstFirst 12345 LastLast

Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum