Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Page 2 of 2 FirstFirst 12
Results 16 to 19 of 19

Thread: Rear wiper sprayer?

  1. #16
    glake89's Avatar
    glake89 is online now Cadillac Owners Connoisseur
    Automobile(s): 05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
    Join Date
    Aug 2010
    Location
    Interlochen,MI
    Age
    82
    Posts
    2,923

    Re: Rear wiper sprayer?

    Yes, but the pump contacts may be bad.

    __________________________________________________ ________________

    This site is too much fun to not be a supporter
    Been fixin' cars for 74 years
    Some of what I know comes from experience, some from reading or listening,-most of it, I just make up

  2. #17
    orandaberg Guest

    Re: Rear wiper sprayer?

    Thanks did not think of the plug being bad If no contact at plug, I will go higher up the wire with the test lamp. After shipping and taxes that switch would cost me well over a 100 bucks, was happy to bench test the pump and found it to work, that was the same price, bad plug may just need cleaning
    Thanks

  3. #18
    Join Date
    Jul 2004
    Posts
    13
    I had same symptoms. Traced the whole line. Turned out to be a crusty nozzle. Earlier post is right on. Flip the pivot cover. Pull straight out very carefully. Clean out with a pin, press in, and aim with pin to spray om window. Nozzle is prone to plugging.

  4. #19
    orandaberg Guest

    Re: Rear wiper sprayer?

    Now the manual shows this as the rear washer pump

    This as the windshield

    If thats the case I have been backwards on this the entire time! I am not at home now to verify but in a week or so I will verify the line up and if thats the case then I tested the wrong motor! But this means pulling the entire bottle out again. PITA! It could be one of the pumps does not work and for a quick fix they just swapped over connections since both are the same

Page 2 of 2 FirstFirst 12

Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum