1973 Wind Shield Wiper Motor ?
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 5 of 5
RWD 19xx-1984 DeVille and Fleetwood,
1985-1996 Fleetwood and Brougham Forum Discussion, 1973 Wind Shield Wiper Motor ? in Past Cadillac Vehicle Discussion; The wiper motor clicks when turned on in my 1973 Cadillac. I took the motor out of my other car, ...
  1. #1
    coodeville is offline Cadillac Owners Member
    Automobile(s): 1970 Couple DeVille 1973 M&M Olympia 1988 Brougham Flower Ca
    Join Date
    Apr 2011
    Posts
    29

    1973 Wind Shield Wiper Motor ?

    The wiper motor clicks when turned on in my 1973 Cadillac. I took the motor out of my other car, which is the same, and put it into the car. Again, it would not work in the '73 but clicked. Any suggestions ? All three bolts are in place to hold the wiper motor in place.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    deVille33 is offline Cadillac Owners Connoisseur
    Automobile(s): 1977 Coupe (blue), 1977 Coupe (yellow), 1977 Coupe (green)
    Join Date
    Mar 2006
    Location
    Western Massachusetts
    Posts
    1,380

    Re: 1973 Wind Shield Wiper Motor ?

    Do the arms move at all? The click may be the solenoid which pulls the lock off the cam for the windshield washer.
    Pull the cover off the control cap and using a test light or voltage meter, check that you are getting a signal from the switch to the motor. Your switch could be your problem.

  4. #3
    coodeville is offline Cadillac Owners Member
    Automobile(s): 1970 Couple DeVille 1973 M&M Olympia 1988 Brougham Flower Ca
    Join Date
    Apr 2011
    Posts
    29

    Re: 1973 Wind Shield Wiper Motor ?

    The arms only move when disconnected from the motor.

  5. #4
    deVille33 is offline Cadillac Owners Connoisseur
    Automobile(s): 1977 Coupe (blue), 1977 Coupe (yellow), 1977 Coupe (green)
    Join Date
    Mar 2006
    Location
    Western Massachusetts
    Posts
    1,380

    Re: 1973 Wind Shield Wiper Motor ?

    Check that you are getting current from the switch to the motor.

  6. #5
    coodeville is offline Cadillac Owners Member
    Automobile(s): 1970 Couple DeVille 1973 M&M Olympia 1988 Brougham Flower Ca
    Join Date
    Apr 2011
    Posts
    29

    Re: 1973 Wind Shield Wiper Motor ?

    I checed. Im getting current at the center terminal of the motor.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting