electrical problem on a 79 coupe
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 12 of 12
RWD 19xx-1984 DeVille and Fleetwood,
1985-1996 Fleetwood and Brougham Forum Discussion, electrical problem on a 79 coupe in Past Cadillac Vehicle Discussion; I have a 1979 coupe deville, while the cars on and im listening to the radio if I turn the ...
  1. #1
    79coupedevile is offline Cadillac Owners Member
    Automobile(s): 1979 cadillac coupe deville
    Join Date
    Jul 2013
    Age
    23
    Posts
    3

    electrical problem on a 79 coupe

    I have a 1979 coupe deville, while the cars on and im listening to the radio if I turn the interior lights on or open the door the radio goes out the clock resets and so do the radio stations, ive owned the car for the last 5 years and is completely 100 percent stock the electrical issue just happened out of nowhere about a year ago I need some help I cant figure out what is causing this to happen

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    cadillac kevin's Avatar
    cadillac kevin is offline Cadillac Owners Master
    Automobile(s): chevy 350 powered 86 FWB, 00 safari h.t. 66 toro, 83 lesabre
    Join Date
    Dec 2010
    Location
    St. Louis, MO
    Posts
    5,606
    Quote Originally Posted by 79coupedevile
    I have a 1979 coupe deville, while the cars on and im listening to the radio if I turn the interior lights on or open the door the radio goes out the clock resets and so do the radio stations, ive owned the car for the last 5 years and is completely 100 percent stock the electrical issue just happened out of nowhere about a year ago I need some help I cant figure out what is causing this to happen
    My guess is it is somehow cutting off power to the radios constant power (memory). Maybe someone installed then removed an aftermarket radio at one point and messed up the wiring harness. I'd remove the radio bezel and put a mulitmeter or test light on the memory wire and see if it loses power when you turn on the interior lights. If no, I'd guess a fault in the radio electronics. It is a weird issue.

  4. #3
    lacville78 is offline Cadillac Owners Fanatic
    Automobile(s): 77 Cadillac CDV
    Join Date
    Feb 2011
    Age
    28
    Posts
    355

    Re: electrical problem on a 79 coupe

    I had these symptoms when my alternator was going out, although the generator light was on too.

  5. #4
    1980coupe's Avatar
    1980coupe is offline Cadillac Owners Connoisseur
    Automobile(s): 78 CDV, 79 CDV delegance, 80 CDV, 80 FWB 2dr delegance (rip)
    Join Date
    Jan 2009
    Location
    El Paso, TX
    Age
    37
    Posts
    1,107

    Re: electrical problem on a 79 coupe

    So the radio is stock?

  6. #5
    The Ape Man's Avatar
    The Ape Man is offline Cadillac Owners Connoisseur
    Automobile(s): '80 Fleetwood Coupe, 1994 and 1995 Mercedes 140 Coupe
    Join Date
    Feb 2005
    Location
    Southern NJ
    Age
    52
    Posts
    2,096

    Re: electrical problem on a 79 coupe

    The body feed fuse that feeds the interior lamps also feeds the radio keep alive memory. That is a clue. If you can't figure it out a diode in series with the radio's keep alive feed cathode end toward radio with a fresh electrolytic cap across the radio side would fill the void. 1N5408 diode, 2200 Uf @ 25 VOLT CAP.

  7. #6
    79coupedevile is offline Cadillac Owners Member
    Automobile(s): 1979 cadillac coupe deville
    Join Date
    Jul 2013
    Age
    23
    Posts
    3

    Re: electrical problem on a 79 coupe

    the body feed fuse would be where in the car? and the car has the stock radio

  8. #7
    The Ape Man's Avatar
    The Ape Man is offline Cadillac Owners Connoisseur
    Automobile(s): '80 Fleetwood Coupe, 1994 and 1995 Mercedes 140 Coupe
    Join Date
    Feb 2005
    Location
    Southern NJ
    Age
    52
    Posts
    2,096

    Re: electrical problem on a 79 coupe

    Quote Originally Posted by 79coupedevile View Post
    the body feed fuse would be where in the car? and the car has the stock radio
    Main fuse panel forward of emergency brake. Should say BODY near fuse. The owner's manual has info too for another check.

  9. #8
    1980coupe's Avatar
    1980coupe is offline Cadillac Owners Connoisseur
    Automobile(s): 78 CDV, 79 CDV delegance, 80 CDV, 80 FWB 2dr delegance (rip)
    Join Date
    Jan 2009
    Location
    El Paso, TX
    Age
    37
    Posts
    1,107

    Re: electrical problem on a 79 coupe

    I know there is another fuse, but I could be wrong since I don't have with me the diagram of fuses. Check at radio for any possible interference
    with the main wires to the radio, orange is constant 12v and yellow is switched 12v..

  10. #9
    carnut is offline Cadillac Owners Master
    Automobile(s): 1988 Allante' (sold), 1984 Eldorado, 84 Sedan DeVille
    Join Date
    Feb 2003
    Location
    california
    Age
    66
    Posts
    5,712

    Re: electrical problem on a 79 coupe

    I will bet the BODY fuse is blown. Usually caused by loose cell phone chargers sparking as they are inserted or removed or tin foil, dimes etc in a lighter socket.

  11. #10
    79coupedevile is offline Cadillac Owners Member
    Automobile(s): 1979 cadillac coupe deville
    Join Date
    Jul 2013
    Age
    23
    Posts
    3

    Re: electrical problem on a 79 coupe

    the body fuse is fine, there was a after market radio installed but it started happening with it installed 2 to 3 years later...

  12. #11
    The Ape Man's Avatar
    The Ape Man is offline Cadillac Owners Connoisseur
    Automobile(s): '80 Fleetwood Coupe, 1994 and 1995 Mercedes 140 Coupe
    Join Date
    Feb 2005
    Location
    Southern NJ
    Age
    52
    Posts
    2,096

    Re: electrical problem on a 79 coupe

    Another possibility would be a marginal ground connection to the radio. If the chassis of the radio floats too high above ground voltage wise it can dump the presets. Some folks only have the ground provided by the antenna lead which can be marginal.

  13. #12
    nyshark is offline Cadillac Owners Member
    Automobile(s): sedan deville 1981
    Join Date
    Jun 2013
    Posts
    21

    Re: electrical problem on a 79 coupe

    I think it has something to do with the dimmer system , The low voltage feeding the radio when you turn interior lighting on forces the low voltage trip out to engage in some after market radios . I just ran a direct feed from positive battery terminal with an inline fuse it has been okay since doing this .

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting