Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 3 of 3

Thread: Deville 79 blower motor doesent work.

  1. #1
    antoonio is offline Cadillac Owners Member
    Automobile(s): Cadillac Coupe DeVille'79
    Join Date
    May 2010
    Age
    46
    Posts
    20

    Deville 79 blower motor doesent work.

    Hii.

    As i know now, i have been driven couple years without running blower motor. Just figured out that (finally).
    .
    Ok, what i have done.
    1. Cleaning very dirty contacts on the blower case. Nothing.
    2. Giving direct 12V to the blower. It is working.
    3. Reading different stuff from internet and user manual. Seems like burning relay is common problem when motor doesent work.
    4. Managing with relay panel. There is one melting point and no any contacts over there anymore. So, i was quite upset but finally i found one relay, which is similar with that http://www.texasindustrialelectric.c...0332209150.asp.
    Not sure, but it can be one part of blower system. It is installed afterward, not factory installing. 5th "leg" of this relay is emty, no wireing there. 5th= in the middle.
    5. Testing wires, there is 2 wires, producing 12 v and 2 wires no volts in ther without relay and no engine running.
    6. Got new relay, a bit powerful 30/40A piece. No changes, motor doesent work.
    7. tested vacuum, with direc 12v to the blower and using eco, low-med-hi-bilevel and etc airflowe will be redirected.
    8. At moment not too much ideas. Should i go to to programmer to chec these contacts, or shoudl i go by wires and must check all connections. Actually i have no ideas where these wires is going to from relay .


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    deVille33 is offline Cadillac Owners Connoisseur
    Automobile(s): 1977 Coupe (blue), 1977 Coupe (yellow), 1977 Coupe (green)
    Join Date
    Mar 2006
    Location
    Western Massachusetts
    Posts
    1,493

    Re: Deville 79 blower motor doesent work.

    I have the schematics for this system and it is very hard to follow. Started making my own isolating the CC system from the rest of circuitry. Would have to see if I can find that file again. Check the Main power to the blower. It is a 10 gauge wire. Also check the resistor pack that sets in the top of the air box. Sometimes the coils get corroded and add to the resistance of the circuit going back to the programmer. If you search through these threads, you will find this subject has been covered in depth within the past year.

  4. #3
    antoonio is offline Cadillac Owners Member
    Automobile(s): Cadillac Coupe DeVille'79
    Join Date
    May 2010
    Age
    46
    Posts
    20

    Re: Deville 79 blower motor doesent work.

    Thnx m8.
    So something happened during today.
    Finaly got some result and blower working but not more than low speed. Doesent matter which program u have choosen.
    One of my friend, watched this scheme and told that direct 12 volts is missing (Hi or defrog program), what can be
    ATC main head problem. But it can be also some bad connection in other places. Anyways it is "good" puzzle for me.
    Anyways, it reminds me that this AC never worked better than in low speed as much as long (4 years) i own this car.


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum