1983 deville 4.1L transmission issues
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 7 of 7
RWD 19xx-1984 DeVille and Fleetwood,
1985-1996 Fleetwood and Brougham Forum Discussion, 1983 deville 4.1L transmission issues in Past Cadillac Vehicle Discussion; replaced tcc solenoid and 4th gear pressure switch. can someone please help me here. At times car stumbles when I'm ...
  1. #1
    caddy1983 is offline Cadillac Owners Fanatic
    Automobile(s): 1983 Fleetwood brougham 2 door
    Join Date
    Oct 2009
    Posts
    103

    1983 deville 4.1L transmission issues

    replaced tcc solenoid and 4th gear pressure switch. can someone please help me here. At times car stumbles when I'm coming to a stop from cruising speed. any ideas? when it hits second and starts jerking. feels like a manual transmission if you dont
    give enough gas when letting clutch out. also engine seems to bog down and I can hear the valves pinging. other than this
    the tranny feels fine. I posted an issue a few months ago about my tcc solenoid. now that its been replaced im getting these symtoms. The car has 243000 original miles and runs great. car has been in the family since new. Car has been well
    maintained. I will be scanning this tomorrow to see if any codes come up. I found info. on line that I may have to reflash the pcm to its factory settings. Is this correct info. Can I just disconnect the battery to see if it resets on its own. Ant help will
    be appreciated.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    cadillac_al is offline Cadillac Owners Connoisseur
    Automobile(s): Cadillac 78 Seville, 78 Coupe de Ville, 92 Sedan de Ville
    Join Date
    Feb 2007
    Location
    Maine
    Age
    53
    Posts
    2,721

    Re: 1983 deville 4.1L transmission issues

    That jerking in 2nd gear sounds similar to FWD Buick 3.8's that have bad plug wires or EGR issues. How long since the last ignition tune up? Does the 4.1 have EGR tubes under the throttle body that need to be cleaned?

    Do you think the TV cable has ever been touched? When I had a Olds 98 with 200r4 trans I could never ever get the TV cable adjusted right. That was 20 years ago and I was just figuring them out.

    It does seem related to the tc lockup too but I don't have any ideas on that at the moment. Hopefully some code will come up to point you in the right direction. It could be vacuum or MAP related too.

  4. #3
    The Ape Man's Avatar
    The Ape Man is offline Cadillac Owners Connoisseur
    Automobile(s): '80 Fleetwood Coupe, 1994 and 1995 Mercedes 140 Coupe
    Join Date
    Feb 2005
    Location
    Southern NJ
    Age
    52
    Posts
    2,096

    Re: 1983 deville 4.1L transmission issues

    I suggest probing the lockup solenoid voltage supply while test driving. The pinout and procedure is contained in the shop manual.

  5. #4
    caddy1983 is offline Cadillac Owners Fanatic
    Automobile(s): 1983 Fleetwood brougham 2 door
    Join Date
    Oct 2009
    Posts
    103

    Re: 1983 deville 4.1L transmission issues

    recently tuned up and replaced egr about 2 years ago with oem parts. replaced due to smog check. before i replaced the tcc solenoid, i had the
    tcc solenoid
    connector disconnected from the outside of the tranny because i knew i had a bad tcc solenoid. i did not experience this problem with the
    connector disconnected. tranny running
    fine but my highway rpm where a bit high. this was not a problem because i would cruise on the freeway going about 60mph. now with the tcc
    solenoid replaced I can go 80mph without feeling my tranny in high rpm's. but now i have this problem when i decrease my speed to about 25mph.
    this is when i feel my car bogging and the pinging noise ocurring. what I do here is give it some gas to increase my speed to 30-35mph and the
    bogging and
    pinging stop and my car runs great. what can be causing this issue?

  6. #5
    carnut is offline Cadillac Owners Master
    Automobile(s): 1988 Allante' (sold), 1984 Eldorado, 84 Sedan DeVille
    Join Date
    Feb 2003
    Location
    california
    Age
    66
    Posts
    5,733

    Re: 1983 deville 4.1L transmission issues

    Drive the car on the freeway and enable the diagnostics thru the OFF and Warmer buttons. At speeds above 60 MPH the orange icon will light up above the word AUTO on the display panel if voltage is getting to the TCC solenoid. Slightly depressing the brake pedal should turn off the orange icon. If it does not, then you have a wiring issue thru the brake lamp switch wiring. If the icon stays lit, the solenoid never disengages thus the chuggle, jerk, knocking coming to a stop. Do your brake lights work? if that switch is faulty, then the TCC might not get the signal to disengage. Its a very simple system. Voltage is always present at the connector to the TCC with engine running. Once the computer sees the right engine temperature and engine RPM among other things, it supplies a ground signal to the TCC harness, thereby completing the TCC circuit locking the torque converter. When you step on the brake pedal, that ground circuit is interrupted.

  7. #6
    caddy1983 is offline Cadillac Owners Fanatic
    Automobile(s): 1983 Fleetwood brougham 2 door
    Join Date
    Oct 2009
    Posts
    103

    Re: 1983 deville 4.1L transmission issues

    I will try that technique. My brake lights do work. I had the brake light go on one or two times before but never thought this might be a problem.
    Brake light doesn't come on only a couple of times. I replaced my power booster and my brake cylinder a few years ago. How do you reset the computer without disconnecting the battery. Or how do you reflash the computer to factory specs?

  8. #7
    carnut is offline Cadillac Owners Master
    Automobile(s): 1988 Allante' (sold), 1984 Eldorado, 84 Sedan DeVille
    Join Date
    Feb 2003
    Location
    california
    Age
    66
    Posts
    5,733

    Re: 1983 deville 4.1L transmission issues

    There is no "reflashing" disconnecting the battery simply erases any codes stored. The brake warning light can come on if the fluid's low or if the belt driven vacuum pump is weak. Report back after you've been in diagnostics and tell us if the AUTO button lights up above 60 with light throttle.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting