right front turn signal not working
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 14 of 14
Like Tree2Likes
  • 4 Post By cadillac kevin
RWD 19xx-1984 DeVille and Fleetwood,
1985-1996 Fleetwood and Brougham Forum Discussion, right front turn signal not working in Past Cadillac Vehicle Discussion; I have a problem with my 86 FWB. The right turn signal does not work (lights stay bright and don't ...
  1. #1
    cadillac kevin's Avatar
    cadillac kevin is offline Cadillac Owners Master
    Automobile(s): chevy 350 powered 86 FWB, 00 safari h.t. 66 toro, 83 lesabre
    Join Date
    Dec 2010
    Location
    St. Louis, MO
    Posts
    5,631

    right front turn signal not working

    I have a problem with my 86 FWB. The right turn signal does not work (lights stay bright and don't blink when you turn on the signal). The left side works fine.
    I tried the hazard switch, and the left side worked fine and the right rear worked fine, but the right front stayed constant bright. I tried replacing the turn signal bulb and even the running lights on the right front, but it still stays constantly bright when the signal is on. Does anyone have any ideas? I checked all the running and signal lights on the car, and they all work. I'm guessing maybe a bad socket or a bad ground (couldn't find the ground for the turn signal bulb on the right front)

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    csbuckn is offline Cadillac Owners Master
    Automobile(s): 84 Coupe w/500
    Join Date
    Jan 2008
    Location
    Minneapolis
    Posts
    5,136
    The easy way out of this would be to get an electric flasher instead of a thermal one. For whatever reason, your blinker circuit is not heating up the thermal flasher enough for it to blink(break).

    Edit...is it just the front but the back blinks?

  4. #3
    AElayyat's Avatar
    AElayyat is online now Cadillac Owners Connoisseur
    Automobile(s): 85 Fleetwood Brougham, 90 Brougham 5.7, 05 Deville DTS
    Join Date
    Feb 2004
    Location
    So. Cali
    Age
    32
    Posts
    1,091
    If the right side don't work front & back it's the flasher, easy fix.

    IF its only the front not working you may have other issues going on...

  5. #4
    cadillac kevin's Avatar
    cadillac kevin is offline Cadillac Owners Master
    Automobile(s): chevy 350 powered 86 FWB, 00 safari h.t. 66 toro, 83 lesabre
    Join Date
    Dec 2010
    Location
    St. Louis, MO
    Posts
    5,631
    The right side doesn't work when it's on blinker.
    When it's on flasher, only the right front doesn't work.

  6. #5
    AElayyat's Avatar
    AElayyat is online now Cadillac Owners Connoisseur
    Automobile(s): 85 Fleetwood Brougham, 90 Brougham 5.7, 05 Deville DTS
    Join Date
    Feb 2004
    Location
    So. Cali
    Age
    32
    Posts
    1,091
    Quote Originally Posted by cadillac kevin
    The right side doesn't work when it's on blinker.
    When it's on flasher, only the right front doesn't work.
    Got ya..I had a similar problem a while back with my 85, my issue was that the the turn signal bulb had a broken contact, changed the bulb & all was good again.

    I would also look at the wiring to make sure nothing is broken.

    Hopefully your issue is a simple fix.

  7. #6
    cadillac kevin's Avatar
    cadillac kevin is offline Cadillac Owners Master
    Automobile(s): chevy 350 powered 86 FWB, 00 safari h.t. 66 toro, 83 lesabre
    Join Date
    Dec 2010
    Location
    St. Louis, MO
    Posts
    5,631
    Quote Originally Posted by AElayyat

    Got ya..I had a similar problem a while back with my 85, my issue was that the the turn signal bulb had a broken contact, changed the bulb & all was good again.

    I would also look at the wiring to make sure nothing is broken.

    Hopefully your issue is a simple fix.
    I thought it was the bulb, but I changed it for a new bulb and still have the same problem (wouldn't think a new bulb would be defective). According to the FSM, its either an open ground or the signal switch.

  8. #7
    jayoldschool's Avatar
    jayoldschool is offline GM RWD V8 addict
    Automobile(s): 81 FWB D'Elegance coupe
    Join Date
    Sep 2006
    Location
    Ontario, Canada
    Age
    41
    Posts
    6,799

    Re: right front turn signal not working

    Swap the bulbs side to side to completely rule the bulb out.

  9. #8
    cadillac kevin's Avatar
    cadillac kevin is offline Cadillac Owners Master
    Automobile(s): chevy 350 powered 86 FWB, 00 safari h.t. 66 toro, 83 lesabre
    Join Date
    Dec 2010
    Location
    St. Louis, MO
    Posts
    5,631
    Quote Originally Posted by jayoldschool
    Swap the bulbs side to side to completely rule the bulb out.
    Will do (thankfully, I haven't replaced the rear fillers yet, so I can just reach in and get a bulb from the backside). IIRC, I didn't have a problem until I changed my front turn signal lenses from orange to clear (and the bulbs from clear to orange)

  10. #9
    mjs182004's Avatar
    mjs182004 is offline Cadillac Owners Enthusiast
    Automobile(s): 91 Brougham d' Elegance, 06 STS-V
    Join Date
    Dec 2008
    Location
    Eastlake, Ohio
    Age
    28
    Posts
    644

    Re: right front turn signal not working

    I had the same issue. It turned out to be a broken wire towards the back by the drivers side taillight (this problem was on the drivers side). I just wire nutted them together for the time being, and when I get time, I will solder them back together. The guy who had it before me spliced into the taillight harness for the trailer wires. lets just say, that it was not done properly.

  11. #10
    csbuckn is offline Cadillac Owners Master
    Automobile(s): 84 Coupe w/500
    Join Date
    Jan 2008
    Location
    Minneapolis
    Posts
    5,136
    I know some bulbs have a high and low side. Maybe its in backwards if its possible with that bulb. Usually noticeable by how one running light is brighter then the other.

  12. #11
    cadillac_al is offline Cadillac Owners Connoisseur
    Automobile(s): Cadillac 78 Seville, 78 Coupe de Ville, 92 Sedan de Ville
    Join Date
    Feb 2007
    Location
    Maine
    Age
    53
    Posts
    2,721

    Re: right front turn signal not working

    Try an extra ground wire on that light. I had an issue once with a weak ground and now that blinker housing has 2 ground wires.

  13. #12
    cadillac kevin's Avatar
    cadillac kevin is offline Cadillac Owners Master
    Automobile(s): chevy 350 powered 86 FWB, 00 safari h.t. 66 toro, 83 lesabre
    Join Date
    Dec 2010
    Location
    St. Louis, MO
    Posts
    5,631
    Quote Originally Posted by cadillac_al
    Try an extra ground wire on that light. I had an issue once with a weak ground and now that blinker housing has 2 ground wires.
    I don't even know where the factory ground is for that light. I'm guessing I should splice into it and run a wire to the core support or inner fenders?

  14. #13
    1980coupe's Avatar
    1980coupe is offline Cadillac Owners Connoisseur
    Automobile(s): 78 CDV, 79 CDV delegance, 80 CDV, 80 FWB 2dr delegance (rip)
    Join Date
    Jan 2009
    Location
    El Paso, TX
    Age
    37
    Posts
    1,112

    Re: right front turn signal not working

    The ground wires are tied into the harness and its bolted to the radiator support.
    Check to see if all the bulbs are the right numbered model for the application
    Also it could be your directional signal switch is going bad. Thats located on the steering column.

  15. #14
    cadillac kevin's Avatar
    cadillac kevin is offline Cadillac Owners Master
    Automobile(s): chevy 350 powered 86 FWB, 00 safari h.t. 66 toro, 83 lesabre
    Join Date
    Dec 2010
    Location
    St. Louis, MO
    Posts
    5,631
    Figured I'd resolve this issue (in case anyone has the same problem). The bulb was in backwards. Glad it was a pretty quick and easy fix

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting