Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 3 of 3

Thread: cruise control not working properly!

  1. #1
    Join Date
    Jan 2004
    Location
    north carolina
    Age
    50
    Posts
    32

    cruise control not working properly!

    w/cruise set it won't accelarate w/accel button,and when going up hill let's say at 70 mph it backs down to about 55 mph any help w/this please


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    elwesso's Avatar
    elwesso is offline Cadillac Owners Master
    Automobile(s): 2005 CTS-V, 1994 Infiniti Q45
    Join Date
    Jan 2003
    Location
    Indiana
    Posts
    7,661

    Re: cruise control not working properly!

    Do you have any diagnostic trouble codes? I konw that the OBD will throw a few codes for cruise control...

    Turn the ignition on, press OFF and WARMER at the same time, and tell me what the display reads out.....

  4. #3
    Aurora By Olds is offline Cadillac Owners Fanatic
    Automobile(s): 2000 DTS
    Join Date
    Oct 2003
    Location
    Fort Myers, FL
    Age
    33
    Posts
    197

    Re: cruise control not working properly!

    OBD I will doubtfuly throw any codes for cruise control.
    Find the servo under the hood, and check for good strong vacuum from each of the vacuum lines while the engine is running.
    If you don't suspect any vacuum leaks, then I would look at servo replacement.
    I don't know how to test one, maybe someone else can give a little heads up on that.
    I know in my dad's delta 88 work car, its gone through a few in its 200k mile lifespan.


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum